summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wireshark/files/wireshark-1.12.8-gtk-deprecated-warnings.patch')
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.12.8-gtk-deprecated-warnings.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/wireshark/files/wireshark-1.12.8-gtk-deprecated-warnings.patch b/net-analyzer/wireshark/files/wireshark-1.12.8-gtk-deprecated-warnings.patch
new file mode 100644
index 00000000000..24ecf9fc449
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.12.8-gtk-deprecated-warnings.patch
@@ -0,0 +1,28 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1536,25 +1536,6 @@
+ wireshark_man=""
+ fi
+
+-if test "$have_gtk" = "yes" ; then
+- # If we have GTK then add flags for it.
+-
+- CPPFLAGS="-DGDK_DISABLE_DEPRECATED $CPPFLAGS"
+- if test \( $gtk_config_major_version -eq 3 -a $gtk_config_minor_version -ge 10 \) ; then
+- ## Allow use of deprecated & disable deprecated warnings if Gtk >= 3.10;
+- ## The deprecations in Gtk 3.10 will not be fixed ...
+- CPPFLAGS="-DGDK_DISABLE_DEPRECATION_WARNINGS $CPPFLAGS"
+- else
+- CPPFLAGS="-DGTK_DISABLE_DEPRECATED $CPPFLAGS"
+- fi
+- CPPFLAGS="-DGTK_DISABLE_SINGLE_INCLUDES $CPPFLAGS"
+- if test ! \( $gtk_config_major_version -eq 2 -a $gtk_config_minor_version -lt 20 \) ; then
+- # Enable GSEAL when building with GTK > 2.20
+- # (Versions prior to 2.22 lacked some necessary accessors.)
+- CPPFLAGS="-DGSEAL_ENABLE $CPPFLAGS"
+- fi
+-fi
+-
+ # XXX - Is this really necessary? When we build with both Gtk+ and Qt it works...
+ if test "$use_glib_cflags" = "true"; then
+ # Use GLIB_CFLAGS