summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/xprobe/xprobe-0.3-r1.ebuild')
-rw-r--r--net-analyzer/xprobe/xprobe-0.3-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-analyzer/xprobe/xprobe-0.3-r1.ebuild b/net-analyzer/xprobe/xprobe-0.3-r1.ebuild
index db0208e8db4a..d630b7fd1214 100644
--- a/net-analyzer/xprobe/xprobe-0.3-r1.ebuild
+++ b/net-analyzer/xprobe/xprobe-0.3-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
MY_P=${PN}2-${PV}
@@ -9,6 +10,7 @@ MY_P=${PN}2-${PV}
DESCRIPTION="Active OS fingerprinting tool - this is Xprobe2"
HOMEPAGE="http://sys-security.com/blog/xprobe2"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="GPL-2"
SLOT="0"
@@ -16,14 +18,16 @@ KEYWORDS="~amd64 ~ppc ~sparc x86"
DEPEND="net-libs/libpcap"
RDEPEND="${DEPEND}"
+
PATCHES=(
"${FILESDIR}"/${P}-gcc43.patch
"${FILESDIR}"/${P}-cxx11.patch
+ "${FILESDIR}"/${P}-gcc-12.patch
)
-S=${WORKDIR}/${MY_P}
src_prepare() {
default
+
sed -i -e 's:strip:true:' src/Makefile.in || die
sed -i -e 's:ar cr:$(AR) cr:g' $(find -name '*Makefile*') || die
@@ -32,5 +36,6 @@ src_prepare() {
src_install() {
default
+
dodoc AUTHORS CHANGELOG CREDITS README TODO docs/*.{txt,pdf}
}