summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/xl2tpd')
-rw-r--r--net-dialup/xl2tpd/files/xl2tpd-init-r16
-rw-r--r--net-dialup/xl2tpd/files/xl2tpd.conf2
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.16-r1.ebuild (renamed from net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild)14
3 files changed, 17 insertions, 5 deletions
diff --git a/net-dialup/xl2tpd/files/xl2tpd-init-r1 b/net-dialup/xl2tpd/files/xl2tpd-init-r1
index 4e9956a4d13d..82366c69f57c 100644
--- a/net-dialup/xl2tpd/files/xl2tpd-init-r1
+++ b/net-dialup/xl2tpd/files/xl2tpd-init-r1
@@ -1,11 +1,11 @@
#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
command="/usr/sbin/xl2tpd"
-pidfile="/var/run/xl2tpd.pid"
+pidfile="/run/xl2tpd.pid"
required_files="/etc/xl2tpd/xl2tpd.conf"
start_pre() {
- checkpath -d /var/run/xl2tpd
+ checkpath -d /run/xl2tpd
}
diff --git a/net-dialup/xl2tpd/files/xl2tpd.conf b/net-dialup/xl2tpd/files/xl2tpd.conf
index 67162b26df06..32119f564439 100644
--- a/net-dialup/xl2tpd/files/xl2tpd.conf
+++ b/net-dialup/xl2tpd/files/xl2tpd.conf
@@ -1 +1 @@
-d /var/run/xl2tpd
+d /run/xl2tpd
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.16-r1.ebuild
index 5821a9c07fe3..59d581b60f81 100644
--- a/net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild
+++ b/net-dialup/xl2tpd/xl2tpd-1.3.16-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,6 +24,18 @@ RDEPEND="
DOCS=( CREDITS README.md BUGS CHANGES TODO doc/README.patents )
+src_prepare() {
+ default
+ sed -e 's:/var/run/:/run/:' -i \
+ file.h \
+ l2tp.h \
+ xl2tpd-control.c \
+ doc/l2tp-secrets.5 \
+ doc/xl2tpd.8 \
+ doc/xl2tpd.conf.5 \
+ || die "Error updating /var/run to /run"
+}
+
src_compile() {
tc-export CC
local OSFLAGS="-DLINUX"