summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/rp-pppoe/Manifest1
-rw-r--r--net-dialup/rp-pppoe/files/rp-pppoe-3.10-session-offset.patch21
-rw-r--r--net-dialup/rp-pppoe/rp-pppoe-3.11-r3.ebuild97
3 files changed, 0 insertions, 119 deletions
diff --git a/net-dialup/rp-pppoe/Manifest b/net-dialup/rp-pppoe/Manifest
index 1644caa49473..fac075dbc804 100644
--- a/net-dialup/rp-pppoe/Manifest
+++ b/net-dialup/rp-pppoe/Manifest
@@ -1,4 +1,3 @@
DIST ppp-2.4.7.tar.gz 688117 BLAKE2B e1c94ce31d98674536929d19e956e4013eb2b02c20c34e6184c0b99b50262ad1cd7fb6f4a1ed302872527a0c164af340e15ad1e2eaf191392c3f6ae2de21f5dd SHA512 e34ce24020af6a73e7a26c83c4f73a9c83fa455b7b363794dba27bf01f70368be06bff779777843949bd77f4bc9385d6ad455ea48bf8fff4e0d73cc8fef16ae2
-DIST rp-pppoe-3.11.tar.gz 223234 BLAKE2B 48a733f2b454284934a123383c32484e5715f131dd45e78a1dd8844dc7e9da74a62f2d4e144b8d57e30652be6eefef480d88a7b61fade7312a47ea750ddcbcda SHA512 cb9579ad94f6b6cfd709e8061aacac0a007f1f58ffd50bd0603f5a2b612c0cf4831febdbfeee290b97932fd30f8ae7f707d532a291124c4aeae2333131d53905
DIST rp-pppoe-3.12.tar.gz 224125 BLAKE2B 27fe75e794624acaeb81806d67a6f4e5601a6b6a466100898ae3cccc8acb5f72ad9275fecd28735df1b01162ff0e60b74ad0373a24a60c7a5731b0744b86e019 SHA512 1b9e4c806fcbad1bc21f7b74a780ae98682b10a69d91fb08df6dbd1fff86f6271995ebded43f926f8249a17cdddb541edccbbb3ee28e1a2dc89173ad61cd3de1
DIST rp-pppoe-3.13.tar.gz 224204 BLAKE2B 8ac3cd59c809f7f2e10fea580dfbda20fc99ae443851513cdc6d0ba8e8df848d7bd6f10d2b0ac6592bc4b48ee1945c299d3cbd73eb9dd6ddc23d0c1c39cd1b77 SHA512 e29ddc39252a0e71d509096e275f6f195f86a5871052dd558e8fb174d13086b1c601e6652f45619279a1eb2fbda96ba0ec85dea9edb27459af56ded4a52b5f36
diff --git a/net-dialup/rp-pppoe/files/rp-pppoe-3.10-session-offset.patch b/net-dialup/rp-pppoe/files/rp-pppoe-3.10-session-offset.patch
deleted file mode 100644
index 303ecfa9e4b7..000000000000
--- a/net-dialup/rp-pppoe/files/rp-pppoe-3.10-session-offset.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Nru rp-pppoe-3.10.orig/src/pppoe-server.c rp-pppoe-3.10/src/pppoe-server.c
---- rp-pppoe-3.10.orig/src/pppoe-server.c 2008-06-30 16:00:43.000000000 +0200
-+++ rp-pppoe-3.10/src/pppoe-server.c 2008-06-30 22:35:11.000000000 +0200
-@@ -1751,7 +1751,7 @@
- }
- if (PassUnitOptionToPPPD) {
- argv[c++] = "unit";
-- sprintf(buffer, "%u", (unsigned int) (ntohs(session->sess) - 1 - SessOffset));
-+ sprintf(buffer, "%u", (unsigned int) (ntohs(session->sess) - 1));
- argv[c++] = buffer;
- }
- argv[c++] = NULL;
-@@ -1834,7 +1834,7 @@
- argv[c++] = "default-asyncmap";
- if (PassUnitOptionToPPPD) {
- argv[c++] = "unit";
-- sprintf(buffer, "%u", (unsigned int) (ntohs(session->sess) - 1 - SessOffset));
-+ sprintf(buffer, "%u", (unsigned int) (ntohs(session->sess) - 1));
- argv[c++] = buffer;
- }
- argv[c++] = NULL;
diff --git a/net-dialup/rp-pppoe/rp-pppoe-3.11-r3.ebuild b/net-dialup/rp-pppoe/rp-pppoe-3.11-r3.ebuild
deleted file mode 100644
index 256fe45f563d..000000000000
--- a/net-dialup/rp-pppoe/rp-pppoe-3.11-r3.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic autotools readme.gentoo
-
-PPP_P="ppp-2.4.7"
-
-DESCRIPTION="A user-mode PPPoE client and server suite for Linux"
-HOMEPAGE="https://www.roaringpenguin.com/products/pppoe"
-SRC_URI="http://www.roaringpenguin.com/files/download/${P}.tar.gz
- https://www.samba.org/ftp/pub/ppp/${PPP_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 ~sh sparc x86"
-IUSE="tk"
-
-RDEPEND="
- net-dialup/ppp:=
- tk? ( dev-lang/tk )
-"
-DEPEND=">=sys-kernel/linux-headers-2.6.25
- ${RDEPEND}"
-
-DOC_CONTENTS="Use pppoe-setup to configure your dialup connection"
-
-pkg_setup() {
- # This is needed in multiple phases
- PPPD_VER=$(best_version net-dialup/ppp)
- PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
- PPPD_VER=${PPPD_VER%%-*} #reduce it to ${PV}
-}
-
-src_prepare() {
- # Patch to enable integration of pppoe-start and pppoe-stop with
- # baselayout-1.11.x so that the pidfile can be found reliably per interface
- epatch "${FILESDIR}/${PN}-3.10-gentoo-netscripts.patch"
-
- epatch "${FILESDIR}/${PN}-3.10-username-charset.patch" # bug 82410
- epatch "${FILESDIR}/${PN}-3.10-plugin-options.patch"
- epatch "${FILESDIR}/${PN}-3.10-autotools.patch"
- epatch "${FILESDIR}/${PN}-3.10-session-offset.patch" # bug 204476
- has_version '<sys-kernel/linux-headers-2.6.35' && \
- epatch "${FILESDIR}/${PN}-3.10-linux-headers.patch" #334197
- epatch "${FILESDIR}/${PN}-3.10-posix-source-sigaction.patch"
- epatch "${FILESDIR}/${PN}-3.11-gentoo.patch"
- epatch "${FILESDIR}/${PN}-3.11-kmode.patch" #364941
-
- cd "${S}"/src || die
- eautoreconf
-}
-
-src_configure() {
- addpredict /dev/ppp
-
- cd "${S}/src" || die
- econf --enable-plugin=../../ppp-${PPPD_VER}
-}
-
-src_compile() {
- cd "${S}/src" || die
- emake
-
- if use tk; then
- emake -C "${S}/gui" || die "gui make failed"
- fi
-}
-
-src_install () {
- cd "${S}/src" || die
- emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
-
- #Don't use compiled rp-pppoe plugin - see pkg_preinst below
- local pppoe_plugin="${D}/etc/ppp/plugins/rp-pppoe.so"
- if [ -f "${pppoe_plugin}" ] ; then
- rm "${pppoe_plugin}" || die
- fi
-
- if use tk; then
- emake -C "${S}/gui" \
- DESTDIR="${D}" \
- datadir=/usr/share/doc/${PF}/ \
- install
- dosym /usr/share/doc/${PF}/tkpppoe /usr/share/tkpppoe
- fi
-
- readme.gentoo_create_doc
-}
-
-pkg_preinst() {
- # Use the rp-pppoe plugin that comes with net-dialup/pppd
- if [ -n "${PPPD_VER}" ] && [ -f "${ROOT}/usr/lib/pppd/${PPPD_VER}/rp-pppoe.so" ] ; then
- dosym /usr/lib/pppd/${PPPD_VER}/rp-pppoe.so /etc/ppp/plugins/rp-pppoe.so
- fi
-}