summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnsviz/dnsviz-0.8.2-r1.ebuild')
-rw-r--r--net-dns/dnsviz/dnsviz-0.8.2-r1.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/net-dns/dnsviz/dnsviz-0.8.2-r1.ebuild b/net-dns/dnsviz/dnsviz-0.8.2-r1.ebuild
index c2613635b249..aaee35f2902a 100644
--- a/net-dns/dnsviz/dnsviz-0.8.2-r1.ebuild
+++ b/net-dns/dnsviz/dnsviz-0.8.2-r1.ebuild
@@ -35,6 +35,19 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+python_test() {
+ distutils_install_for_testing
+
+ "${EPYTHON}" tests/offline_tests.py -v || die
+
+ # No need to pull in net-dns/bind for this small test
+ if hash named-checkconf &>/dev/null ; then
+ "${EPYTHON}" tests/local_probe_tests.py -v || die
+ else
+ einfo "Skipping local_probe_tests -- named-checkconf not found!"
+ fi
+}
+
pkg_postinst() {
elog "Support for extra feature can be get from:"
optfeature "Support for pre-deployment testing" net-dns/bind