summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/resolv_wrapper/resolv_wrapper-1.1.4.ebuild')
-rw-r--r--net-dns/resolv_wrapper/resolv_wrapper-1.1.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-dns/resolv_wrapper/resolv_wrapper-1.1.4.ebuild b/net-dns/resolv_wrapper/resolv_wrapper-1.1.4.ebuild
new file mode 100644
index 000000000000..949d14d871f3
--- /dev/null
+++ b/net-dns/resolv_wrapper/resolv_wrapper-1.1.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A wrapper for DNS name resolving or DNS faking"
+HOMEPAGE="https://cwrap.org/resolv_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+ local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+ cmake-utils_src_configure
+}