summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/knot/knot-3.0.7.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-dns/knot/knot-3.0.7.ebuild b/net-dns/knot/knot-3.0.7.ebuild
index ff2ab85cf4eb..b4082a371f4a 100644
--- a/net-dns/knot/knot-3.0.7.ebuild
+++ b/net-dns/knot/knot-3.0.7.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd
+inherit flag-o-matic systemd
DESCRIPTION="High-performance authoritative-only DNS server"
HOMEPAGE="https://www.knot-dns.cz/"
@@ -11,7 +11,7 @@ SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~riscv ~x86"
KNOT_MODULES=(
"+cookies"
@@ -73,6 +73,10 @@ src_configure() {
my_conf+=("$(use_with ${u} module-${u})")
done
+ if use riscv; then
+ append-libs -latomic
+ fi
+
econf "${my_conf[@]}"
}