summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/resolv_wrapper/resolv_wrapper-1.1.5.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/net-dns/resolv_wrapper/resolv_wrapper-1.1.5.ebuild b/net-dns/resolv_wrapper/resolv_wrapper-1.1.5.ebuild
index ba89b7e9fb90..f936bc18a143 100644
--- a/net-dns/resolv_wrapper/resolv_wrapper-1.1.5.ebuild
+++ b/net-dns/resolv_wrapper/resolv_wrapper-1.1.5.ebuild
@@ -1,25 +1,22 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
-DESCRIPTION="A wrapper for DNS name resolving or DNS faking"
+DESCRIPTION="Wrapper for DNS name resolving or DNS faking"
HOMEPAGE="https://cwrap.org/resolv_wrapper.html"
SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
# Because of this we cannot use cmake-multilib_src_configure() here.
multilib_src_configure() {
local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
- cmake-utils_src_configure
+ cmake_src_configure
}