summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/openresolv/Manifest1
-rw-r--r--net-dns/openresolv/openresolv-3.11.0.ebuild42
-rw-r--r--net-dns/openresolv/openresolv-3.9.0.ebuild2
-rw-r--r--net-dns/openresolv/openresolv-3.9.2.ebuild2
4 files changed, 43 insertions, 4 deletions
diff --git a/net-dns/openresolv/Manifest b/net-dns/openresolv/Manifest
index bb865fe16c20..8c719faa916c 100644
--- a/net-dns/openresolv/Manifest
+++ b/net-dns/openresolv/Manifest
@@ -1,3 +1,4 @@
DIST openresolv-3.10.0.tar.xz 20296 BLAKE2B 2e4fc22aebeb345fcdcc5395603a183a978e2ea24a4b419d76ab41e5179b640e3a317d5f1ef36bc6901d933b20daaca615489c785a41d76a89abc938c20e2723 SHA512 f28fc43887f18f6cbdcdabbb48777fc704ed653e77f34caf349b5c4e5f5f6e7686242ea9f2617f2f65d40d14c794ce28cffee0ec5e5c7b8a19566f3bd72e9ec5
+DIST openresolv-3.11.0.tar.xz 20552 BLAKE2B 5564ecac60124fa391a13979da533c4f7cf99601acc896cb5d3cc029bff15ef48ea36e867a0fc6d1e6e475a7536660fbd819120b3066dd2aadc12abf0e16c8ff SHA512 09708b8a1abf7de926f75a1825d4243be6e59fc1de7cc3d7ab7f5a317e11175bd24af03bff2c878ccc54c96913feed27630765647c70fec8a9f9aa7370744e24
DIST openresolv-3.9.0.tar.xz 18844 BLAKE2B 0aa2125d79305aab04a8d052d56328493d51aa6ff5b44fdfe08e96ccc78ae1d84f2115e5d59940e7e1cedf7e4fe7dc36a461839bcef8fc2c5b2e21242e441f36 SHA512 4498db60f0b5a762194dd3651b94cc8b01a349a8cfb891e10d040cd6b8e22fa0e9897909517831591787ad22ffad97c78d3281e32296aa1ee67de5dff9bf765e
DIST openresolv-3.9.2.tar.xz 20200 BLAKE2B 25cb56fd85114c3866207a3bf83d1295eb135f1746f141d8cb8f0fb18cdd96e184ad3fbb47d1f65ce4193b57da61e918ca4306a502eaba650ca438589be9a29b SHA512 2f88ccbb53c6e830eeb7dd53666ee72b9fa30f38324766e1d1734896bc9b7f531e42e234c882b921c79604a3bde2877db2681bab9dd8c590f02779da908d0649
diff --git a/net-dns/openresolv/openresolv-3.11.0.ebuild b/net-dns/openresolv/openresolv-3.11.0.ebuild
new file mode 100644
index 000000000000..45ba61bc2c8d
--- /dev/null
+++ b/net-dns/openresolv/openresolv-3.11.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="https://roy.marples.name/projects/openresolv"
+SRC_URI="https://roy.marples.name/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-resolvconf )"
+
+src_configure() {
+ local myeconfargs=(
+ --prefix="${EPREFIX}"
+ --rundir="${EPREFIX}"/var/run
+ --libexecdir="${EPREFIX}"/lib/resolvconf
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_config() {
+ if [[ ${ROOT} != / ]]; then
+ eerror "We cannot configure unless \$ROOT=/"
+ return 1
+ fi
+
+ if [[ -n "$(resolvconf -l)" ]]; then
+ einfo "${PN} already has DNS information"
+ else
+ ebegin "Copying /etc/resolv.conf to resolvconf -a dummy"
+ resolvconf -a dummy </etc/resolv.conf
+ eend $? || return $?
+ einfo "The dummy interface will disappear when you next reboot"
+ fi
+}
+
+DOCS=( LICENSE README.md )
diff --git a/net-dns/openresolv/openresolv-3.9.0.ebuild b/net-dns/openresolv/openresolv-3.9.0.ebuild
index dde233146880..bf2ea346e270 100644
--- a/net-dns/openresolv/openresolv-3.9.0.ebuild
+++ b/net-dns/openresolv/openresolv-3.9.0.ebuild
@@ -12,8 +12,6 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
IUSE="selinux"
-DEPEND="!net-dns/resolvconf-gentoo
- !<net-dns/dnsmasq-2.40-r1"
RDEPEND="selinux? ( sec-policy/selinux-resolvconf )"
src_configure() {
diff --git a/net-dns/openresolv/openresolv-3.9.2.ebuild b/net-dns/openresolv/openresolv-3.9.2.ebuild
index 7efc80a0a9a3..763dc738699d 100644
--- a/net-dns/openresolv/openresolv-3.9.2.ebuild
+++ b/net-dns/openresolv/openresolv-3.9.2.ebuild
@@ -12,8 +12,6 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="selinux"
-DEPEND="!net-dns/resolvconf-gentoo
- !<net-dns/dnsmasq-2.40-r1"
RDEPEND="selinux? ( sec-policy/selinux-resolvconf )"
src_configure() {