summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/minio')
-rw-r--r--net-fs/minio/Manifest1
-rw-r--r--net-fs/minio/files/minio.initd11
-rw-r--r--net-fs/minio/minio-0_pre20171122.ebuild52
3 files changed, 64 insertions, 0 deletions
diff --git a/net-fs/minio/Manifest b/net-fs/minio/Manifest
index 66c8030646b8..a99b30105ef7 100644
--- a/net-fs/minio/Manifest
+++ b/net-fs/minio/Manifest
@@ -1,2 +1,3 @@
DIST minio-0_pre20170929.tar.gz 6976881 SHA256 6e78d07d272630f1cad4cd7950a19206bdadaa2b6721f74df65ec85dd88b36a0 SHA512 f22ab87f4fadbe332acd7db9155fff5fb79c55357071627397d51b3a2c26eaf7f80c53b9ed37822d72948610d3d1805e70abaca6f3e39b26c3c1e4e6770cae44 WHIRLPOOL bd43ae7b1dcd196e90db5ffac8aa6643435af76582147ac50890221ff964a1cf36d8fe8411ae47148bb5cd0929f09c541c11abbaa3eb54c2efb40f3368104894
DIST minio-0_pre20171027.tar.gz 6904926 SHA256 62f3baf0312302f3a3066f941157ba7d4347cfbaa13748e5786d1890a8a906e5 SHA512 15be3adf502efb9eecf2ef83a8339a1c965ee9ff6507e4a61e13faa187a3592cd88f9868716ce2834e54dde03f3bec12337a68e72fbaddf103c880ce3c4554f2 WHIRLPOOL 4c0af6e2ef356f1590dd99cbd754ef52e276791944e1776833ace870d5969c8e53f29cda554369458764bffe6891a7a51ac69590a958d7ae69622ecb48de79e0
+DIST minio-0_pre20171122.tar.gz 7030932 BLAKE2B a06b81bcc16c9880a13a615f894d04f55e6824feed603bb466e0d95c6ed1b1e9c28b639e5ef6240e0d33ac17791465def51bf7b92f7a9c836c0a20541d2b422c SHA512 06f404381c33a053c402b90b1353b4a5284923bb5b5264eef5b6a59fa94e6f85f4bf8306a865bba2eeccdf4b484e92c1d353a7a15d8dacc1a5d8c11d108dc8fe
diff --git a/net-fs/minio/files/minio.initd b/net-fs/minio/files/minio.initd
new file mode 100644
index 000000000000..3e64ba16f75e
--- /dev/null
+++ b/net-fs/minio/files/minio.initd
@@ -0,0 +1,11 @@
+#!/sbin/openrc-run
+# Copyright 2016-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Minio Object Storage Server"
+pidfile=${pidfile:-"/run/${SVCNAME}.pid"}
+command="/usr/bin/minio"
+command_args="${command_args:-server /var/lib/minio}"
+command_background="true"
+start_stop_daemon_args="--stdout /var/log/${SVCNAME}.log \
+ --stderr /var/log/${SVCNAME}.log"
diff --git a/net-fs/minio/minio-0_pre20171122.ebuild b/net-fs/minio/minio-0_pre20171122.ebuild
new file mode 100644
index 000000000000..f542c660635a
--- /dev/null
+++ b/net-fs/minio/minio-0_pre20171122.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/minio/minio"
+VERSION="2017-11-22T19-55-46Z"
+EGIT_COMMIT="d1a6c32d800f1d5b703baad1f8aeede6cf2cdf48"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="An Amazon S3 compatible object storage server"
+HOMEPAGE="https://github.com/minio/minio"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/time.Now().UTC().Format(time.RFC3339)/\"${VERSION}\"/"\
+ -e "s/-s //"\
+ -e "/time/d"\
+ -e "s/+ commitID()/+ \"${EGIT_COMMIT}\"/"\
+ src/${EGO_PN}/buildscripts/gen-ldflags.go || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ MINIO_RELEASE="${VERSION}"
+ go run buildscripts/gen-ldflags.go
+ GOPATH="${S}" go build --ldflags "$(go run buildscripts/gen-ldflags.go)" -o ${PN} || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dodoc -r README.md CONTRIBUTING.md MAINTAINERS.md docs
+ dobin minio
+ popd || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+}