summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/sshfs/sshfs-3.6.0.ebuild')
-rw-r--r--net-fs/sshfs/sshfs-3.6.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-fs/sshfs/sshfs-3.6.0.ebuild b/net-fs/sshfs/sshfs-3.6.0.ebuild
new file mode 100644
index 000000000000..2bf50acbf8d6
--- /dev/null
+++ b/net-fs/sshfs/sshfs-3.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Fuse-filesystem utilizing the sftp service"
+HOMEPAGE="https://github.com/libfuse/sshfs"
+SRC_URI="https://github.com/libfuse/${PN}/releases/download/${P}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+DEPEND=">=sys-fs/fuse-3.1.0:3
+ >=dev-libs/glib-2.4.2"
+RDEPEND="${DEPEND}
+ >=net-misc/openssh-4.4"
+BDEPEND="dev-python/docutils
+ virtual/pkgconfig"
+
+# requires root privs and specific localhost sshd setup
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog.rst README.rst )