summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/nfs-utils-2.3.3.ebuild14
-rw-r--r--net-fs/nfs-utils/nfs-utils-2.3.4.ebuild14
-rw-r--r--net-fs/nfs-utils/nfs-utils-2.4.1.ebuild14
3 files changed, 24 insertions, 18 deletions
diff --git a/net-fs/nfs-utils/nfs-utils-2.3.3.ebuild b/net-fs/nfs-utils/nfs-utils-2.3.3.ebuild
index b98297ce0b07..77465d97e588 100644
--- a/net-fs/nfs-utils/nfs-utils-2.3.3.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-2.3.3.ebuild
@@ -179,12 +179,14 @@ pkg_postinst() {
done
if systemd_is_booted; then
- if [[ ${REPLACING_VERSIONS} < 1.3.0 ]]; then
- ewarn "We have switched to upstream systemd unit files. Since"
- ewarn "they got renamed, you should probably enable the new ones."
- ewarn "You can run 'equery files nfs-utils | grep systemd'"
- ewarn "to know what services you need to enable now."
- fi
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 1.3.0; then
+ ewarn "We have switched to upstream systemd unit files. Since"
+ ewarn "they got renamed, you should probably enable the new ones."
+ ewarn "You can run 'equery files nfs-utils | grep systemd'"
+ ewarn "to know what services you need to enable now."
+ fi
+ done
else
ewarn "If you use OpenRC, the nfsmount service has been replaced with nfsclient."
ewarn "If you were using nfsmount, please add nfsclient and netmount to the"
diff --git a/net-fs/nfs-utils/nfs-utils-2.3.4.ebuild b/net-fs/nfs-utils/nfs-utils-2.3.4.ebuild
index dafe5f83ce34..975b78c549b1 100644
--- a/net-fs/nfs-utils/nfs-utils-2.3.4.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-2.3.4.ebuild
@@ -176,12 +176,14 @@ pkg_postinst() {
done
if systemd_is_booted; then
- if [[ ${REPLACING_VERSIONS} < 1.3.0 ]]; then
- ewarn "We have switched to upstream systemd unit files. Since"
- ewarn "they got renamed, you should probably enable the new ones."
- ewarn "You can run 'equery files nfs-utils | grep systemd'"
- ewarn "to know what services you need to enable now."
- fi
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 1.3.0; then
+ ewarn "We have switched to upstream systemd unit files. Since"
+ ewarn "they got renamed, you should probably enable the new ones."
+ ewarn "You can run 'equery files nfs-utils | grep systemd'"
+ ewarn "to know what services you need to enable now."
+ fi
+ done
else
ewarn "If you use OpenRC, the nfsmount service has been replaced with nfsclient."
ewarn "If you were using nfsmount, please add nfsclient and netmount to the"
diff --git a/net-fs/nfs-utils/nfs-utils-2.4.1.ebuild b/net-fs/nfs-utils/nfs-utils-2.4.1.ebuild
index aff15752fd00..0fcea1be6f26 100644
--- a/net-fs/nfs-utils/nfs-utils-2.4.1.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-2.4.1.ebuild
@@ -187,12 +187,14 @@ pkg_postinst() {
done
if systemd_is_booted; then
- if [[ ${REPLACING_VERSIONS} < 1.3.0 ]]; then
- ewarn "We have switched to upstream systemd unit files. Since"
- ewarn "they got renamed, you should probably enable the new ones."
- ewarn "You can run 'equery files nfs-utils | grep systemd'"
- ewarn "to know what services you need to enable now."
- fi
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 1.3.0; then
+ ewarn "We have switched to upstream systemd unit files. Since"
+ ewarn "they got renamed, you should probably enable the new ones."
+ ewarn "You can run 'equery files nfs-utils | grep systemd'"
+ ewarn "to know what services you need to enable now."
+ fi
+ done
else
ewarn "If you use OpenRC, the nfsmount service has been replaced with nfsclient."
ewarn "If you were using nfsmount, please add nfsclient and netmount to the"