summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/samba-4.0.26-r1.ebuild (renamed from net-fs/samba/samba-4.0.26.ebuild)4
-rw-r--r--net-fs/samba/samba-4.1.20-r1.ebuild (renamed from net-fs/samba/samba-4.1.20.ebuild)6
-rw-r--r--net-fs/samba/samba-4.2.3-r1.ebuild (renamed from net-fs/samba/samba-4.2.3.ebuild)6
3 files changed, 14 insertions, 2 deletions
diff --git a/net-fs/samba/samba-4.0.26.ebuild b/net-fs/samba/samba-4.0.26-r1.ebuild
index e3ef3e481adf..c4ee74a91f91 100644
--- a/net-fs/samba/samba-4.0.26.ebuild
+++ b/net-fs/samba/samba-4.0.26-r1.ebuild
@@ -152,6 +152,10 @@ src_install() {
# Make all .so files executable
find "${D}" -type f -name "*.so" -exec chmod +x {} +
+ # install example config file
+ insinto /etc/samba
+ doins examples/smb.conf.default
+
# Install init script and conf.d file
newinitd "${CONFDIR}/samba4.initd-r1" samba
newconfd "${CONFDIR}/samba4.confd" samba
diff --git a/net-fs/samba/samba-4.1.20.ebuild b/net-fs/samba/samba-4.1.20-r1.ebuild
index 3b8e63e772eb..9a1ba22572e8 100644
--- a/net-fs/samba/samba-4.1.20.ebuild
+++ b/net-fs/samba/samba-4.1.20-r1.ebuild
@@ -148,6 +148,10 @@ src_install() {
# Make all .so files executable
find "${D}" -type f -name "*.so" -exec chmod +x {} +
+ # install example config file
+ insinto /etc/samba
+ doins examples/smb.conf.default
+
# Install init script and conf.d file
newinitd "${CONFDIR}/samba4.initd-r1" samba
newconfd "${CONFDIR}/samba4.confd" samba
@@ -172,6 +176,6 @@ pkg_postinst() {
elog "For further information and migration steps make sure to read "
elog "http://samba.org/samba/history/${P}.html "
- elog "http://samba.org/samba/history/${PN}-4.0.0.html and"
+ elog "http://samba.org/samba/history/${PN}-4.1.0.html and"
elog "http://wiki.samba.org/index.php/Samba4/HOWTO "
}
diff --git a/net-fs/samba/samba-4.2.3.ebuild b/net-fs/samba/samba-4.2.3-r1.ebuild
index fa13c21e8f45..f6aff1b934af 100644
--- a/net-fs/samba/samba-4.2.3.ebuild
+++ b/net-fs/samba/samba-4.2.3-r1.ebuild
@@ -154,6 +154,10 @@ src_install() {
# Make all .so files executable
find "${D}" -type f -name "*.so" -exec chmod +x {} +
+ # install example config file
+ insinto /etc/samba
+ doins examples/smb.conf.default
+
# Install init script and conf.d file
newinitd "${CONFDIR}/samba4.initd-r1" samba
newconfd "${CONFDIR}/samba4.confd" samba
@@ -178,6 +182,6 @@ pkg_postinst() {
elog "For further information and migration steps make sure to read "
elog "http://samba.org/samba/history/${P}.html "
- elog "http://samba.org/samba/history/${PN}-4.0.0.html and"
+ elog "http://samba.org/samba/history/${PN}-4.2.0.html and"
elog "http://wiki.samba.org/index.php/Samba4/HOWTO "
}