summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/cifs-utils/Manifest1
-rw-r--r--net-fs/cifs-utils/cifs-utils-6.10.ebuild121
-rw-r--r--net-fs/cifs-utils/files/cifs-utils-6.10-ln_in_destdir.patch15
3 files changed, 137 insertions, 0 deletions
diff --git a/net-fs/cifs-utils/Manifest b/net-fs/cifs-utils/Manifest
index dbd5aeb88d8f..a95c5f03d970 100644
--- a/net-fs/cifs-utils/Manifest
+++ b/net-fs/cifs-utils/Manifest
@@ -1,3 +1,4 @@
+DIST cifs-utils-6.10.tar.bz2 364221 BLAKE2B 45b692fb85217a25b7042fbe7e40cc8c4fe0d6cc9c905acde2c6fc9c3048343064e376f47128bcacba88f745452148040ad3f5e8ca15e297531f0dc868e1b75b SHA512 e19ca69b7948f01c1fd6a4ed069e00511588b903a5b8b0dc35ac1e00743170b9ca180b747c47d56cfacf273b296da21df60e1957404f26ebf2ba80bfa7e275cc
DIST cifs-utils-6.7.tar.bz2 363647 BLAKE2B 692c4b7de92c2cc5cb88591fb5b5b01ca7d925b105d10f7149e350d1b1661bb6447e71e0ca86095a9e294637d80126e54295413a685786b62c8e70cf26f893d0 SHA512 ee050a0eb4a72fbc8d773e86fbe6839ea2bf11cda5ebd071c8ead66e31b46d50ea4e1d1b26478373be53227cd60b32a90b65b5cb989b5a8237cddfc65bad8e5e
DIST cifs-utils-6.8.tar.bz2 384426 BLAKE2B 002518f44489aefc94c47a23438b176a4056ff4d995b3ed9f25a6c6c8d4c8d7437a3158d5c592d16cb6bfcd289b937d6ac1ef0573c346993d576a88aa1fcb118 SHA512 54a094f78c9e07acc997adfe0c8d4c2fb8e15c18adcc1805450e2180f8539aaec8619e781e985b289e097932637e2de3e6815e32f59ec2fc06cfc3762b832e13
DIST cifs-utils-6.9.tar.bz2 400430 BLAKE2B fc8cc55fae54d84fc1f1d4a14a9d666d87a3da78d1502f0d72ac9cb44ff1424ca2c5b15b0be510579d4c9f5181980627efedd00e0e5cfb1b3e47188ba307ad28 SHA512 b92e4e39eeed1032bb175659296cde034703fb3ca63aae00419d46a33dadf821fedaf03734128112c164c84bcbb48d92d03cdc275c4a7cba26f984aeca40a40a
diff --git a/net-fs/cifs-utils/cifs-utils-6.10.ebuild b/net-fs/cifs-utils/cifs-utils-6.10.ebuild
new file mode 100644
index 000000000000..63cd03fbe6d5
--- /dev/null
+++ b/net-fs/cifs-utils/cifs-utils-6.10.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info multilib pam
+
+DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
+HOMEPAGE="https://wiki.samba.org/index.php/LinuxCIFS_utils"
+SRC_URI="https://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="+acl +ads +caps creds pam"
+
+RDEPEND="
+ !net-fs/mount-cifs
+ !<net-fs/samba-3.6_rc1
+ sys-apps/keyutils:=
+ ads? (
+ sys-libs/talloc
+ virtual/krb5
+ )
+ caps? ( sys-libs/libcap-ng )
+ pam? ( sys-libs/pam )
+"
+DEPEND="${RDEPEND}"
+PDEPEND="
+ acl? ( >=net-fs/samba-4.0.0_alpha1 )
+"
+
+REQUIRED_USE="acl? ( ads )"
+
+DOCS="doc/linux-cifs-client-guide.odt"
+
+PATCHES=( "${FILESDIR}/${PN}-6.10-ln_in_destdir.patch" )
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
+ ewarn "You must enable CIFS support in your kernel config, "
+ ewarn "to be able to mount samba shares. You can find it at"
+ ewarn
+ ewarn " File systems"
+ ewarn " Network File Systems"
+ ewarn " CIFS support"
+ ewarn
+ ewarn "and recompile your kernel ..."
+ fi
+}
+
+src_prepare() {
+ default
+
+ if has_version app-crypt/heimdal ; then
+ # https://bugs.gentoo.org/612584
+ eapply "${FILESDIR}/${PN}-6.7-heimdal.patch"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-smbinfo
+ $(use_enable acl cifsacl cifsidmap)
+ $(use_enable ads cifsupcall)
+ $(use_with caps libcap)
+ $(use_enable creds cifscreds)
+ $(use_enable pam)
+ $(use_with pam pamdir $(getpam_mod_dir))
+ )
+ ROOTSBINDIR="${EPREFIX}"/sbin \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # remove empty directories
+ find "${ED}" -type d -empty -delete || die
+
+ if use acl ; then
+ dodir /etc/cifs-utils
+ dosym ../../usr/$(get_libdir)/cifs-utils/idmapwb.so \
+ /etc/cifs-utils/idmap-plugin
+ dodir /etc/request-key.d
+ echo 'create cifs.idmap * * /usr/sbin/cifs.idmap %k' \
+ > "${ED}/etc/request-key.d/cifs.idmap.conf"
+ fi
+
+ if use ads ; then
+ dodir /etc/request-key.d
+ echo 'create dns_resolver * * /usr/sbin/cifs.upcall %k' \
+ > "${ED}/etc/request-key.d/cifs.upcall.conf"
+ echo 'create cifs.spnego * * /usr/sbin/cifs.upcall %k' \
+ > "${ED}/etc/request-key.d/cifs.spnego.conf"
+ fi
+}
+
+pkg_postinst() {
+ # Inform about set-user-ID bit of mount.cifs
+ ewarn "setuid use flag was dropped due to multiple security implications"
+ ewarn "such as CVE-2009-2948, CVE-2011-3585 and CVE-2012-1586"
+ ewarn "You are free to set setuid flags by yourself"
+
+ # Inform about upcall usage
+ if use acl ; then
+ einfo "The cifs.idmap utility has been enabled by creating the"
+ einfo "configuration file /etc/request-key.d/cifs.idmap.conf"
+ einfo "This enables you to get and set CIFS acls."
+ fi
+
+ if use ads ; then
+ einfo "The cifs.upcall utility has been enabled by creating the"
+ einfo "configuration file /etc/request-key.d/cifs.upcall.conf"
+ einfo "This enables you to mount DFS shares."
+ fi
+}
diff --git a/net-fs/cifs-utils/files/cifs-utils-6.10-ln_in_destdir.patch b/net-fs/cifs-utils/files/cifs-utils-6.10-ln_in_destdir.patch
new file mode 100644
index 000000000000..b2c00bf500db
--- /dev/null
+++ b/net-fs/cifs-utils/files/cifs-utils-6.10-ln_in_destdir.patch
@@ -0,0 +1,15 @@
+--- cifs-utils-6.10/Makefile.am
++++ cifs-utils-6.10/Makefile.am
+@@ -119,10 +119,10 @@
+ SUBDIRS = contrib
+
+ install-exec-hook:
+- (cd $(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
++ (cd $(DESTDIR)$(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
+
+ install-data-hook:
+- (cd $(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
++ (cd $(DESTDIR)$(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
+
+ uninstall-hook:
+ (cd $(ROOTSBINDIR) && rm -f $(ROOTSBINDIR)/mount.smb3)