summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/Manifest1
-rw-r--r--net-ftp/lftp/lftp-4.6.4.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/net-ftp/lftp/Manifest b/net-ftp/lftp/Manifest
index 30d894867569..1e17350b9b86 100644
--- a/net-ftp/lftp/Manifest
+++ b/net-ftp/lftp/Manifest
@@ -1 +1,2 @@
DIST lftp-4.6.3a.tar.xz 1505164 SHA256 8c3a12a1f9ec288132b245bdd7d14d88ade1aa5cb1c14bb68c8fab3b68793840 SHA512 1ecc1e71f73b9713c14cadf1792d56afa41b59e86219743076cf59310db2063335dbc69f58de00c34a1527c3be595959867f964bc7dba2f4989b3625899eac21 WHIRLPOOL a9678e9787317d74349aae1a7bd2db94f11437c522c72f8aac85c7ffb8f8f4efdb00f7d8aeaf27c47e33730e7e11614a1c95b02ca3a3d87b5560b70e74eb0939
+DIST lftp-4.6.4.tar.xz 1508952 SHA256 1e7cb674c83ace48172263f86847ed04bb6ab2f24116b11a8505f70a15e8805c SHA512 998050c0e69fc590233df8b400664c1165dfa80d7b3844aa307be33e004c3dd3e049df8f288ad7079257a31dc4adcdb07a57b8f28cd0adf7e3cf94c41d38b9dc WHIRLPOOL d79849970ff72eda2f5dccd3ce16b619e37661b60152363d96c13d94e4045d24e568b265bb27c8ef809fbfb18c6e31884ae28dba0d0bf6fc252c87ea82ca1396
diff --git a/net-ftp/lftp/lftp-4.6.4.ebuild b/net-ftp/lftp/lftp-4.6.4.ebuild
new file mode 100644
index 000000000000..dd2804f56a5b
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.6.4.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils libtool
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="${HOMEPAGE}ftp/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+IUSE="convert-mozilla-cookies +gnutls idn nls openssl socks5 +ssl verify-file"
+LFTP_LINGUAS=( cs de es fr it ja ko pl pt_BR ru uk zh_CN zh_HK zh_TW )
+IUSE+=" ${LFTP_LINGUAS[@]/#/linguas_}"
+
+REQUIRED_USE="
+ ssl? ( ^^ ( openssl gnutls ) )
+"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-5.1
+ dev-libs/expat
+ sys-libs/zlib
+ convert-mozilla-cookies? ( dev-perl/DBI )
+ idn? ( net-dns/libidn )
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam
+ )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ openssl? ( >=dev-libs/openssl-0.9.6 )
+ )
+ verify-file? (
+ dev-perl/string-crc32
+ virtual/perl-Digest-MD5
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+ =sys-devel/libtool-2*
+ app-arch/xz-utils
+ nls? ( >=sys-devel/gettext-0.19 )
+ virtual/pkgconfig
+"
+
+DOCS=(
+ BUGS ChangeLog FAQ FEATURES MIRRORS NEWS README README.debug-levels
+ README.dnssec README.modules THANKS TODO
+)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-4.0.2.91-lafile.patch \
+ "${FILESDIR}"/${PN}-4.5.5-am_config_header.patch \
+ "${FILESDIR}"/${PN}-4.6.3a-autopoint.patch
+
+ eautoreconf
+ elibtoolize # for Darwin bundles
+
+ # bug #536036
+ printf 'set fish:auto-confirm no\nset sftp:auto-confirm no\n' >> ${PN}.conf || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gnutls) \
+ $(use_with idn libidn) \
+ $(use_with openssl openssl "${EPREFIX}"/usr) \
+ $(use_with socks5 socksdante "${EPREFIX}"/usr) \
+ --enable-packager-mode \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --with-modules \
+ --without-included-regex
+}
+
+src_install() {
+ default
+ local script
+ for script in {convert-mozilla-cookies,verify-file}; do
+ use ${script} || { rm "${ED}"/usr/share/${PN}/${script} || die ;}
+ done
+}