summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/proftpd/metadata.xml1
-rw-r--r--net-ftp/proftpd/proftpd-1.3.6-r2.ebuild6
2 files changed, 5 insertions, 2 deletions
diff --git a/net-ftp/proftpd/metadata.xml b/net-ftp/proftpd/metadata.xml
index 7434ca7e6384..d63407ebc65e 100644
--- a/net-ftp/proftpd/metadata.xml
+++ b/net-ftp/proftpd/metadata.xml
@@ -33,6 +33,7 @@ server.</longdescription>
<flag name="shaper">Enable support for the mod_shaper module</flag>
<flag name="sftp">Enable support for the mod_sftp module and optionally mod_sftp_sql and mod_sftp_pam if matching USE flags are enabled</flag>
<flag name="sitemisc">Enable support for the sitemisc module</flag>
+ <flag name="sodium">Use <pkg>dev-libs/libsodium</pkg> for password encryption an key exchange</flag>
<flag name="softquota">Enable support for the quotatab module</flag>
<flag name="trace">Build with trace support. Should not be enabled on production servers</flag>
<flag name="unique_id">Enable support for the mod_unique_id module, every connection gets unique ID.</flag>
diff --git a/net-ftp/proftpd/proftpd-1.3.6-r2.ebuild b/net-ftp/proftpd/proftpd-1.3.6-r2.ebuild
index 6585ad48c894..3286db7e1078 100644
--- a/net-ftp/proftpd/proftpd-1.3.6-r2.ebuild
+++ b/net-ftp/proftpd/proftpd-1.3.6-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -29,7 +29,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="acl authfile ban +caps case clamav copy ctrls deflate diskuse doc dso dynmasq exec ifsession ifversion ident ipv6
kerberos ldap libressl log_forensic memcache msg mysql ncurses nls pam +pcre postgres qos radius
- ratio readme rewrite selinux sftp shaper sitemisc snmp softquota sqlite ssl tcpd test unique_id vroot xinetd"
+ ratio readme rewrite selinux sftp shaper sitemisc snmp sodium softquota sqlite ssl tcpd test unique_id vroot xinetd"
# TODO: geoip
REQUIRED_USE="ban? ( ctrls )
msg? ( ctrls )
@@ -52,6 +52,7 @@ CDEPEND="acl? ( virtual/acl )
pam? ( virtual/pam )
pcre? ( dev-libs/libpcre )
postgres? ( dev-db/postgresql:= )
+ sodium? ( dev-libs/libsodium:0= )
sqlite? ( dev-db/sqlite:3 )
xinetd? ( virtual/inetd )"
DEPEND="${CDEPEND}
@@ -220,6 +221,7 @@ src_configure() {
$(use_enable ssl openssl) \
$(use_enable pam auth-pam) \
$(use_enable pcre) \
+ $(use_enable sodium) \
$(use_enable test tests) \
--enable-trace \
$(use_enable userland_GNU shadow) \