summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/bitlbee-facebook/bitlbee-facebook-1.1.2.ebuild')
-rw-r--r--net-im/bitlbee-facebook/bitlbee-facebook-1.1.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-im/bitlbee-facebook/bitlbee-facebook-1.1.2.ebuild b/net-im/bitlbee-facebook/bitlbee-facebook-1.1.2.ebuild
new file mode 100644
index 000000000000..be0c1efdefc3
--- /dev/null
+++ b/net-im/bitlbee-facebook/bitlbee-facebook-1.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Facebook protocol plugin for BitlBee"
+HOMEPAGE="https://github.com/bitlbee/bitlbee-facebook"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bitlbee/bitlbee-facebook"
+else
+ SRC_URI="https://github.com/bitlbee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ >=net-im/bitlbee-3[plugins]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}