summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/bitlbee/bitlbee-3.5.1.ebuild11
-rw-r--r--net-im/bitlbee/bitlbee-3.6.ebuild11
-rw-r--r--net-im/bitlbee/bitlbee-9999.ebuild11
3 files changed, 12 insertions, 21 deletions
diff --git a/net-im/bitlbee/bitlbee-3.5.1.ebuild b/net-im/bitlbee/bitlbee-3.5.1.ebuild
index 3ce9cca1ef23..4d724abf2b81 100644
--- a/net-im/bitlbee/bitlbee-3.5.1.ebuild
+++ b/net-im/bitlbee/bitlbee-3.5.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit user systemd toolchain-funcs
+inherit systemd toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
@@ -30,6 +30,8 @@ REQUIRED_USE="
"
COMMON_DEPEND="
+ acct-group/bitlbee
+ acct-user/bitlbee
>=dev-libs/glib-2.16
purple? ( net-im/pidgin )
libevent? ( dev-libs/libevent:= )
@@ -52,11 +54,6 @@ RDEPEND="${COMMON_DEPEND}
virtual/logger
xinetd? ( sys-apps/xinetd )"
-pkg_setup() {
- enewgroup bitlbee
- enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
-}
-
src_prepare() {
if [[ ${PV} != "9999" ]]; then
eapply \
diff --git a/net-im/bitlbee/bitlbee-3.6.ebuild b/net-im/bitlbee/bitlbee-3.6.ebuild
index 9df170295b6b..6643e1c5920c 100644
--- a/net-im/bitlbee/bitlbee-3.6.ebuild
+++ b/net-im/bitlbee/bitlbee-3.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit user systemd toolchain-funcs
+inherit systemd toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
@@ -30,6 +30,8 @@ REQUIRED_USE="
"
COMMON_DEPEND="
+ acct-group/bitlbee
+ acct-user/bitlbee
>=dev-libs/glib-2.16
purple? ( net-im/pidgin )
libevent? ( dev-libs/libevent:= )
@@ -51,11 +53,6 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
xinetd? ( sys-apps/xinetd )"
-pkg_setup() {
- enewgroup bitlbee
- enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
-}
-
src_prepare() {
[[ ${PV} != "9999" ]] && eapply "${FILESDIR}"/${PN}-3.5-systemd-user.patch
eapply_user
diff --git a/net-im/bitlbee/bitlbee-9999.ebuild b/net-im/bitlbee/bitlbee-9999.ebuild
index 9df170295b6b..6643e1c5920c 100644
--- a/net-im/bitlbee/bitlbee-9999.ebuild
+++ b/net-im/bitlbee/bitlbee-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit user systemd toolchain-funcs
+inherit systemd toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
@@ -30,6 +30,8 @@ REQUIRED_USE="
"
COMMON_DEPEND="
+ acct-group/bitlbee
+ acct-user/bitlbee
>=dev-libs/glib-2.16
purple? ( net-im/pidgin )
libevent? ( dev-libs/libevent:= )
@@ -51,11 +53,6 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
xinetd? ( sys-apps/xinetd )"
-pkg_setup() {
- enewgroup bitlbee
- enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
-}
-
src_prepare() {
[[ ${PV} != "9999" ]] && eapply "${FILESDIR}"/${PN}-3.5-systemd-user.patch
eapply_user