summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/eggdrop')
-rw-r--r--net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild13
-rw-r--r--net-irc/eggdrop/files/eggdrop-1.6.21-fix-memset.patch11
2 files changed, 19 insertions, 5 deletions
diff --git a/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild b/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild
index f761a3ba3ae0..541c9a3d3d29 100644
--- a/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild
+++ b/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit eutils
@@ -27,15 +27,17 @@ DEPEND="
sys-apps/gentoo-functions
!vanilla? (
mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql[server] )
- ssl? ( dev-libs/openssl )
+ postgres? ( dev-db/postgresql:*[server] )
+ ssl? ( dev-libs/openssl:0= )
)"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
src_prepare() {
- epatch "${FILESDIR}/${P}-fix-gcc5-remove-inline.patch" # bug 571004
+ # fix bug 571004 and a QA warning
+ epatch "${FILESDIR}/${P}-fix-gcc5-remove-inline.patch" \
+ "${FILESDIR}/${P}-fix-memset.patch"
if use vanilla; then
rm -f "${WORKDIR}"/patch/[1-6]*.patch || die
fi
@@ -46,6 +48,7 @@ src_prepare() {
sed -i \
-e '/\$(LD)/s/-o/$(CFLAGS) $(LDFLAGS) &/' \
src/mod/*.mod/Makefile* src/Makefile.in || die
+ default
}
src_configure() {
@@ -98,7 +101,7 @@ src_install() {
src/mod/mystats.mod/tools/mystats.{conf,sql} \
src/mod/pgstats.mod/tools/{pgstats.conf,setup.sql}
- dohtml doc/html/*.html
+ dodoc -r doc/html
dobin "${FILESDIR}"/eggdrop-installer
doman doc/man1/eggdrop.1
diff --git a/net-irc/eggdrop/files/eggdrop-1.6.21-fix-memset.patch b/net-irc/eggdrop/files/eggdrop-1.6.21-fix-memset.patch
new file mode 100644
index 000000000000..f4d60f322dac
--- /dev/null
+++ b/net-irc/eggdrop/files/eggdrop-1.6.21-fix-memset.patch
@@ -0,0 +1,11 @@
+diff --git a/src/md5/md5c.c b/src/md5/md5c.c
+index 4dce058..cfdf97c 100644
+--- a/src/md5/md5c.c
++++ b/src/md5/md5c.c
+@@ -267,5 +267,5 @@ void MD5_Final(unsigned char *result, MD5_CTX *ctx)
+ result[14] = ctx->d >> 16;
+ result[15] = ctx->d >> 24;
+
+- egg_memset(ctx, 0, sizeof(ctx));
++ egg_memset(ctx, 0, sizeof(*ctx));
+ }