summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/polari/Manifest1
-rw-r--r--net-irc/polari/polari-40.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-irc/polari/Manifest b/net-irc/polari/Manifest
index 4341041c7a55..efa92b834ca1 100644
--- a/net-irc/polari/Manifest
+++ b/net-irc/polari/Manifest
@@ -1,2 +1,3 @@
DIST polari-3.36.3.tar.xz 1030640 BLAKE2B 72cee290c21cd0a1f96d25e02993dadba14247bb3b38d2ce62ebbe8670a9c7498e7dd123bef2ab3ffaea78019109697186cee409dd78a554afbbc5b5c4db56b5 SHA512 dcf8018ffdaffe2867ab7c3bbc1c874090df0ff5435ec16746780ae081dc61a0b7ec0e58d706b6e7eb8957b1f3fe9c24b586db831ab8b0565fa05c1bf3adae38
DIST polari-3.38.1.tar.xz 1050280 BLAKE2B 7c1e640a62003bda2217d914f9f19d6eea3994f780785334fd681c792653aa3ef1b4e3e4bc05d7bb15a614cc70e317f8e8a55445fe6e03c249f66b6b3e97af3d SHA512 196fd58324e1ee24eb58efcf9e11b9bec1cfd11781cba5d09b34344b7d3715f9bc215c7a3ec3b021ac5e1d2575a8200d8ab896b201488bf7da2acb10beb04262
+DIST polari-40.0.tar.xz 1051416 BLAKE2B ea6aea087ff3ba74e2cf16e848c228c0984eb7e5b7cc16579bbe8ceeb3655babb5dfbf3adbe245b66b590999c5b7e0077630b659d0db00e2da6ce0ac8b0281da SHA512 267eb904286f33e6ac510357de072285889d1c72ca832eb6a8520a20b1c2487708eaa0187d4c91b46b3b8019866f37a9ac036a71dee9cd9c9ad83443df0f146c
diff --git a/net-irc/polari/polari-40.0.ebuild b/net-irc/polari/polari-40.0.ebuild
new file mode 100644
index 000000000000..7cfe9e490f0c
--- /dev/null
+++ b/net-irc/polari/polari-40.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="An IRC client for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Polari"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.43.4:2
+ >=x11-libs/gtk+-3.21.6:3[introspection]
+ net-libs/telepathy-glib[introspection]
+ >=dev-libs/gobject-introspection-1.50:=
+ >=dev-libs/gjs-1.67.2
+
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=app-text/gspell-1.4.0[introspection]
+ x11-libs/pango[introspection]
+ app-crypt/libsecret[introspection]
+ net-libs/libsoup:2.4[introspection]
+ net-im/telepathy-logger[introspection]
+"
+RDEPEND="${DEPEND}
+ >=net-irc/telepathy-idle-0.2
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ dev-lang/spidermonkey:78
+ dev-libs/json-glib
+ )
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}