summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild')
-rw-r--r--net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild b/net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild
new file mode 100644
index 000000000000..f0565f04c47b
--- /dev/null
+++ b/net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic java-pkg-2 toolchain-funcs
+
+DESCRIPTION="NativeThread for priorities on linux for freenet"
+HOMEPAGE="https://www.freenetproject.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-p2p/freenet-0.7
+ virtual/jdk:1.8"
+RDEPEND="virtual/jre:1.8"
+
+S="${WORKDIR}"
+
+src_compile() {
+ append-flags -fPIC
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dolib.so lib${PN}.so
+ dosym lib${PN}.so /usr/$(get_libdir)/libnative.so
+}