summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/cppzmq/cppzmq-0_pre130717-r1.ebuild')
-rw-r--r--net-libs/cppzmq/cppzmq-0_pre130717-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/cppzmq/cppzmq-0_pre130717-r1.ebuild b/net-libs/cppzmq/cppzmq-0_pre130717-r1.ebuild
new file mode 100644
index 000000000000..b44c84e6828f
--- /dev/null
+++ b/net-libs/cppzmq/cppzmq-0_pre130717-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="High-level CPP Binding for ZeroMQ"
+HOMEPAGE="https://github.com/zeromq/cppzmq"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=net-libs/zeromq-3"
+DEPEND=""
+
+src_install() {
+ doheader zmq.hpp
+ dodoc README
+}
+
+src_test() {
+ $(tc-getCC) -c ./zmq.hpp -L ./.libs/ -I ./include/ -o ./test.o || die "This version of cppzmq is not compatible with the installed version of net-libs/zeromq"
+ rm -f ./test.o
+}