summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.74.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index 49be85e797b2..ad3a36d5f8a1 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -1,4 +1,3 @@
DIST gsoap_2.8.70.zip 32695627 BLAKE2B 6d803441804badf06b29cee8ca898dc864b9a0388f6f3fa58b84c1b237d77e22ab70e0cc5439915c715bdba7831b14f86d8003e1338b6184ddbfe845bb76ff75 SHA512 f7e9f85580c19bb390f1310bb47b690a5788b54c1e12c6fc0d9166039a84ae24ec5d3268cb67cd72b20e2eaa78689e175b975f07da44fd20e172a77ef37f4ae7
-DIST gsoap_2.8.74.zip 32304642 BLAKE2B cca698d25c837fe70969379a63f849e7623b7bb3c6e4f1fd4e22b159f03a17214981eaf6d9f632a85a6cbff87b4f1ac6411896bb86c083720a94d2bbfd8501ac SHA512 85284b88a94f07f433ffaeb9031c24d4c9c3eb82f8c590fa257cf9392fa0382cdcde5b3d5c7df903c6ddec41b876643b21ea24d18186b03db9dc8a4d6e8477ad
DIST gsoap_2.8.75.zip 32645773 BLAKE2B 120d79a33f90881ef5c4486ffef3a7713770622a65832be9997edeebbd4beac6dbdb6dfd876eb86f8622a1693908e6f56a47b48179fb37fdb12d313e2929ea7e SHA512 f5ebbe307b9125eec2284989a7ec1c16ade93df3b091ac44768750010bf51fdd9199ba96dbdc5b37b105bdd1156a0f90f41fdb407408d62b2c7750881db8b949
DIST gsoap_2.8.76.zip 32474005 BLAKE2B 4b604ea5c21ff98e2eddad3bd032e87e460d708a118ed65cb98e1577a7dc85f7103ffa4ddc4c3447425f4978f7ef72f6c1004fbe6d099a654ef3705fff53bc8a SHA512 4613ce97a52c08267f6186fc90dfa15dac3be0407b754a42ceef59a5f784078c90e43086b9920031d7690a775b42184c330af03c7c594d6cd5b781ff44b1c0b6
diff --git a/net-libs/gsoap/gsoap-2.8.74.ebuild b/net-libs/gsoap/gsoap-2.8.74.ebuild
deleted file mode 100644
index c0cdf5ada9c2..000000000000
--- a/net-libs/gsoap/gsoap-2.8.74.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-MY_P="${PN}-2.8"
-
-DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
-HOMEPAGE="http://gsoap2.sourceforge.net"
-SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
-
-LICENSE="GPL-2 gSOAP"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc debug examples ipv6 libressl gnutls +ssl"
-
-RDEPEND="
- sys-libs/zlib
- gnutls? ( net-libs/gnutls )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl )
- )
-"
-DEPEND="${RDEPEND}
- app-arch/unzip
- sys-devel/flex
- sys-devel/bison
-"
-
-PATCHES=(
- # Fix Pre-ISO headers
- "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
-
- # enable shared libs https://bugs.gentoo.org/583398
- "${FILESDIR}/${PN}-2.8.70-shared_libs.patch"
-
- # Fix parallel make
- "${FILESDIR}/${PN}-2.8.70-parallel.patch"
-)
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- # Don't include xlocale.h as it got removed in >=glibc-2.26
- --disable-xlocale
- $(use_enable debug)
- $(use_enable examples samples)
- $(usex gnutls --enable-gnutls '')
- $(usex ipv6 --enable-ipv6 '')
- $(usex ssl '' --disable-ssl)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- # yes, we also install the license-file since
- # it contains info about how to apply the licenses
- dodoc *.txt
-
- docinto html
- dodoc changelog.md
-
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
-
- if use examples; then
- rm -r gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
- insinto /usr/share/doc/${PF}/examples
- doins -r gsoap/samples/*
- fi
-
- if use doc; then
- docinto html
- dodoc -r gsoap/doc/*
- fi
-}