summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ignition-transport/ignition-transport-2.1.0.ebuild')
-rw-r--r--net-libs/ignition-transport/ignition-transport-2.1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/ignition-transport/ignition-transport-2.1.0.ebuild b/net-libs/ignition-transport/ignition-transport-2.1.0.ebuild
new file mode 100644
index 000000000000..4fecd4cb554b
--- /dev/null
+++ b/net-libs/ignition-transport/ignition-transport-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils vcs-snapshot flag-o-matic
+
+DESCRIPTION="Combines ZeroMQ with Protobufs to create a fast and efficient message passing system"
+HOMEPAGE="http://ignitionrobotics.org/libraries/transport"
+SRC_URI="http://gazebosim.org/distributions/ign-transport/releases/${PN}2-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="2/0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ net-libs/ignition-msgs:=
+ dev-libs/protobuf:=
+ >=net-libs/zeromq-3.2.0:=
+ sys-apps/util-linux
+ net-libs/cppzmq
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=( "${FILESDIR}/protobuf3.patch" )
+S="${WORKDIR}/${PN}2-${PV}"
+
+src_configure() {
+ # upstream appends this conditionally...
+ append-flags "-fPIC"
+ echo "set (CMAKE_C_FLAGS_ALL \"${CXXFLAGS} \${CMAKE_C_FLAGS_ALL}\")" > "${S}/cmake/HostCFlags.cmake"
+ sed -i -e "s/LINK_FLAGS_RELWITHDEBINFO \" \"/LINK_FLAGS_RELWITHDEBINFO \" ${LDFLAGS} \"/" cmake/DefaultCFlags.cmake || die
+ cmake-utils_src_configure
+}