summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libaccounts-glib/libaccounts-glib-1.25-r2.ebuild')
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.25-r2.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.25-r2.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.25-r2.ebuild
deleted file mode 100644
index 5d6c6cb80b40..000000000000
--- a/net-libs/libaccounts-glib/libaccounts-glib-1.25-r2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9,10} )
-inherit meson python-r1 vala
-
-DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
-HOMEPAGE="https://gitlab.com/accounts-sso/libaccounts-glib"
-SRC_URI="https://gitlab.com/accounts-sso/${PN}/-/archive/VERSION_${PV}/${PN}-VERSION_${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-VERSION_${PV}"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-IUSE="doc"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-# fails
-RESTRICT="test"
-
-RDEPEND="${PYTHON_DEPS}
- dev-db/sqlite:3
- dev-libs/glib:2
- dev-libs/gobject-introspection:=
- dev-libs/libxml2
- dev-python/pygobject:3[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- $(vala_depend)
- dev-util/gdbus-codegen
- dev-util/glib-utils
- dev-libs/check
- doc? ( dev-util/gtk-doc )
-"
-
-PATCHES=( "${FILESDIR}/${P}-assert-failure.patch" )
-
-src_prepare() {
- default
- vala_src_prepare --ignore-use
-
- use doc || sed -e "/^subdir('docs')$/d" -i meson.build || die
-}
-
-src_configure() {
- python_foreach_impl run_in_build_dir meson_src_configure
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir meson_src_compile
-}
-
-src_install() {
- einstalldocs
- python_foreach_impl run_in_build_dir meson_src_install
- python_foreach_impl python_optimize
-}