summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libomemo/libomemo-0.8.1.ebuild')
-rw-r--r--net-libs/libomemo/libomemo-0.8.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/libomemo/libomemo-0.8.1.ebuild b/net-libs/libomemo/libomemo-0.8.1.ebuild
new file mode 100644
index 000000000000..ba4a9ee43a58
--- /dev/null
+++ b/net-libs/libomemo/libomemo-0.8.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Implementation of OMEMO (XEP-0384) in C"
+HOMEPAGE="https://github.com/gkdr/libomemo"
+SRC_URI="https://github.com/gkdr/libomemo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-db/sqlite
+ dev-libs/glib
+ dev-libs/libgcrypt
+ dev-libs/mxml
+ "
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/cmocka )
+ "
+
+RESTRICT="!test? ( test )"
+
+DOCS=( CHANGELOG.md README.md )