summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libpcap/libpcap-9999.ebuild')
-rw-r--r--net-libs/libpcap/libpcap-9999.ebuild67
1 files changed, 41 insertions, 26 deletions
diff --git a/net-libs/libpcap/libpcap-9999.ebuild b/net-libs/libpcap/libpcap-9999.ebuild
index 5ad21ee77a4e..770877d74270 100644
--- a/net-libs/libpcap/libpcap-9999.ebuild
+++ b/net-libs/libpcap/libpcap-9999.ebuild
@@ -1,49 +1,65 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit autotools git-r3 multilib-minimal
+EAPI=8
+
+inherit autotools multilib-minimal
DESCRIPTION="A system-independent library for user-level network packet capture"
-EGIT_REPO_URI="https://github.com/the-tcpdump-group/libpcap"
-HOMEPAGE="
- https://www.tcpdump.org/
- https://github.com/the-tcpdump-group/libpcap
-"
+HOMEPAGE="https://www.tcpdump.org/ https://github.com/the-tcpdump-group/libpcap"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/the-tcpdump-group/libpcap"
+ inherit git-r3
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/tcpdump.asc
+ inherit verify-sig
+
+ SRC_URI="https://www.tcpdump.org/release/${P}.tar.gz"
+ SRC_URI+=" verify-sig? ( https://www.tcpdump.org/release/${P}.tar.gz.sig )"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
LICENSE="BSD"
SLOT="0"
-IUSE="bluetooth dbus netlink rdma -remote static-libs usb -yydebug"
-KEYWORDS=""
+IUSE="bluetooth dbus netlink rdma remote static-libs test usb yydebug"
+RESTRICT="!test? ( test )"
RDEPEND="
bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
netlink? ( dev-libs/libnl:3[${MULTILIB_USEDEP}] )
+ remote? ( virtual/libcrypt:=[${MULTILIB_USEDEP}] )
rdma? ( sys-cluster/rdma-core )
usb? ( virtual/libusb:1[${MULTILIB_USEDEP}] )
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/yacc
sys-devel/flex
- virtual/yacc
dbus? ( virtual/pkgconfig )
"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.9.1-pcap-config.patch
- "${FILESDIR}"/${PN}-9999-prefix-darwin.patch
-)
+if [[ ${PV} != *9999* ]] ; then
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-tcpdump )"
+fi
src_prepare() {
default
+ if ! [[ -f VERSION ]]; then
+ echo ${PV} > VERSION || die
+ fi
+
eautoreconf
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" \
- econf \
+ # bug #884275
+ export LEX=flex
+
+ ECONF_SOURCE="${S}" econf \
$(use_enable bluetooth) \
$(use_enable dbus) \
$(use_enable rdma) \
@@ -56,10 +72,15 @@ multilib_src_configure() {
multilib_src_compile() {
emake all shared
+ use test && emake testprogs
+}
+
+multilib_src_test() {
+ testprogs/findalldevstest || die
}
multilib_src_install_all() {
- dodoc CREDITS CHANGES VERSION TODO README*
+ dodoc CREDITS CHANGES VERSION TODO README.* doc/README.*
# remove static libraries (--disable-static does not work)
if ! use static-libs; then
@@ -67,10 +88,4 @@ multilib_src_install_all() {
fi
find "${ED}" -name '*.la' -delete || die
-
- # We need this to build pppd on G/FBSD systems
- if [[ "${USERLAND}" == "BSD" ]]; then
- insinto /usr/include
- doins pcap-int.h portability.h
- fi
}