summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libqmi/libqmi-9999.ebuild')
-rw-r--r--net-libs/libqmi/libqmi-9999.ebuild37
1 files changed, 19 insertions, 18 deletions
diff --git a/net-libs/libqmi/libqmi-9999.ebuild b/net-libs/libqmi/libqmi-9999.ebuild
index 9ae85656240..51ac0339e07 100644
--- a/net-libs/libqmi/libqmi-9999.ebuild
+++ b/net-libs/libqmi/libqmi-9999.ebuild
@@ -1,46 +1,47 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
inherit multilib
if [[ ${PV} == "9999" ]] ; then
inherit git-r3 autotools
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/libqmi.git"
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mobile-broadband/libqmi.git"
else
- KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
SRC_URI="https://www.freedesktop.org/software/libqmi/${P}.tar.xz"
fi
-DESCRIPTION="Qualcomm MSM (Mobile Station Modem) Interface (QMI) modem protocol helper library"
-HOMEPAGE="https://cgit.freedesktop.org/libqmi/"
+DESCRIPTION="Qualcomm MSM (Mobile Station Modem) Interface (QMI) modem protocol library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libqmi/ https://gitlab.freedesktop.org/mobile-broadband/libqmi"
LICENSE="LGPL-2"
-SLOT="0/5.1" # soname of libqmi-glib.so
-IUSE="doc +mbim static-libs"
+SLOT="0/5.7" # soname of libqmi-glib.so
+IUSE="doc +mbim"
-RDEPEND=">=dev-libs/glib-2.36
+RDEPEND=">=dev-libs/glib-2.48
dev-libs/libgudev
- mbim? ( >=net-libs/libmbim-1.14.0 )"
-DEPEND="${RDEPEND}
- doc? ( dev-util/gtk-doc )
- virtual/pkgconfig"
-[[ ${PV} == "9999" ]] && DEPEND+=" dev-util/gtk-doc" #469214
+ mbim? ( >=net-libs/libmbim-1.18.0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+[[ ${PV} == "9999" ]] && BDEPEND+=" dev-util/gtk-doc" #469214
src_prepare() {
default
- [[ -e configure ]] || eautoreconf
+ [[ ${PV} == "9999" ]] && eautoreconf
}
src_configure() {
econf \
- --disable-more-warnings \
+ --disable-Werror \
+ --disable-static \
$(use_enable mbim mbim-qmux) \
- $(use_enable static{-libs,}) \
$(use_enable {,gtk-}doc)
}
src_install() {
default
- use static-libs || rm -f "${ED}/usr/$(get_libdir)/${PN}-glib.la"
+ find "${ED}" -name '*.la' -delete || die
}