summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/xrootd')
-rw-r--r--net-libs/xrootd/Manifest2
-rw-r--r--net-libs/xrootd/xrootd-4.10.1.ebuild113
-rw-r--r--net-libs/xrootd/xrootd-4.9.0.ebuild119
3 files changed, 0 insertions, 234 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index 734b98b5f8b7..45d3d07ef45e 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -1,5 +1,3 @@
-DIST xrootd-4.10.1.tar.gz 2532982 BLAKE2B 79cc334c631060e9be48c4f443837065e786f49513e535150f7490a9a5a17ec91f4f5dd054b0f15cb6b60ecfc18a1447e28825dc7d6665ef59004ab11665f9e2 SHA512 49234db532292c6ef04d455a1a6a5d1ff4d6705c088d5c2571602f444cb9bf03699e63a12ba962a6d3a8b9cc9f43635889ec33976840326a8301c81da7099397
DIST xrootd-4.11.1.tar.gz 2549971 BLAKE2B e131769291d33d2198c4afdedd0d9f9a0eac9459654277763554d2dfba211b7123f3d0dfc90fe365c7f4da2590d9bec6daf994ee7ae241897aa10b4500362c3c SHA512 7853de40d40f28177f70a18f17ee99f83c8b6c6ddf0b5e7ef64df83c5457bad11e6249c75f985c207c3292fab73a2181730ce9c8bf11979535a566c5364de8a1
DIST xrootd-4.12.0.tar.gz 2564041 BLAKE2B 6ea9c379aa482c81279168baa3e1381e880d34014fb3516c96961da64d54faf649295f024313ece445df9a62b6b5c818b7aa8a987025d3cd969188de072648c9 SHA512 5338c4fb5461918473dd4f41f4d29fae09a8fc6a9e2d8f00bb74d929dc5396fef73643462d1a4f1ba71ffe5cf92a1695a167ca3a766c674a9377dcf99aaa1778
DIST xrootd-4.8.3.tar.gz 2390520 BLAKE2B 1b97225c41f6a3a751f55a4d357f53fac2e4cc24f2456962a6d6282b78faaeb844db5d69bff34437acd2c015dbff4a2a5047d6295770abd200d3e5bedd89d4fe SHA512 6f605131be18f35115bf7cf5d829dfd5a36e004ac69aa77dd0cb34ab70f2b89ff07e7b3e3259fe672d81b6241596c78a537de02e5abad4537dc92ae745ae8911
-DIST xrootd-4.9.0.tar.gz 2517614 BLAKE2B 5f1ce6f599fdf5b1f9b4fa078d9b306be241757f95e9b5e9bc0a6f06450a21315778428d8c1d1ffd28ef0841bc50fca387036740bb707d9a96b7f07e94e15540 SHA512 a956262a8adae4c9cb9a91275d4207943cf43251fc61ade111c91152c62baf06c1cbdf1d659c6d792703045a4c2a82bac732220ecfd2fa707e445d6fc66ee047
diff --git a/net-libs/xrootd/xrootd-4.10.1.ebuild b/net-libs/xrootd/xrootd-4.10.1.ebuild
deleted file mode 100644
index bdfdc4d72002..000000000000
--- a/net-libs/xrootd/xrootd-4.10.1.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit cmake-utils python-single-r1 user
-
-DESCRIPTION="Extended ROOT remote file server"
-HOMEPAGE="http://xrootd.org/"
-SRC_URI="http://xrootd.org/download/v${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples fuse http kerberos python readline ssl test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- sys-libs/zlib
- fuse? ( sys-fs/fuse:= )
- kerberos? ( virtual/krb5 )
- python? ( ${PYTHON_DEPS} )
- readline? ( sys-libs/readline:0= )
- ssl? ( dev-libs/openssl:0= )
-"
-DEPEND="${CDEPEND}
- doc? (
- app-doc/doxygen[dot]
- python? ( dev-python/sphinx )
- )
- test? ( dev-util/cppunit )
-"
-RDEPEND="${CDEPEND}
- dev-lang/perl
-"
-REQUIRED_USE="
- http? ( kerberos ssl )
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-PATCHES=( "${FILESDIR}"/xrootd-4.8.3-crc32.patch )
-
-# xrootd plugins are not intended to be linked with,
-# they are to be loaded at runtime by xrootd,
-# see https://github.com/xrootd/xrootd/issues/447
-QA_SONAME="/usr/lib.*/libXrd*-4.so"
-
-pkg_setup() {
- enewgroup xrootd
- enewuser xrootd -1 -1 "${EPREFIX}"/var/spool/xrootd xrootd
- use python && python_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_CRYPTO=$(usex ssl)
- -DENABLE_FUSE=$(usex fuse)
- -DENABLE_HTTP=$(usex http)
- -DENABLE_KRB5=$(usex kerberos)
- -DENABLE_PYTHON=$(usex python)
- -DENABLE_READLINE=$(usex readline)
- -DENABLE_TESTS=$(usex test)
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use doc; then
- doxygen Doxyfile || die
- if use python; then
- emake -C bindings/python/docs html
- fi
- fi
-}
-
-src_install() {
- use doc && HTML_DOCS=( doxydoc/html/. )
- dodoc docs/ReleaseNotes.txt
- cmake-utils_src_install
- find "${D}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
-
- # base configs
- insinto /etc/xrootd
- doins packaging/common/*.cfg
-
- fowners root:xrootd /etc/xrootd
- keepdir /var/log/xrootd
- fowners xrootd:xrootd /var/log/xrootd
-
- local i
- for i in cmsd frm_purged frm_xfrd xrootd; do
- newinitd "${FILESDIR}"/${i}.initd ${i}
- done
- # all daemons MUST use single master config file
- newconfd "${FILESDIR}"/xrootd.confd xrootd
-
- if use python; then
- python_optimize "${D}/$(python_get_sitedir)"
-
- if use doc; then
- docinto python
- docompress -x "/usr/share/doc/${PF}/python/html"
- dodoc -r bindings/python/docs/build/html
- fi
- if use examples; then
- docinto python
- dodoc -r bindings/python/examples
- fi
- fi
-}
diff --git a/net-libs/xrootd/xrootd-4.9.0.ebuild b/net-libs/xrootd/xrootd-4.9.0.ebuild
deleted file mode 100644
index 55c0653ee3be..000000000000
--- a/net-libs/xrootd/xrootd-4.9.0.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-single-r1 user
-
-DESCRIPTION="Extended ROOT remote file server"
-HOMEPAGE="http://xrootd.org/"
-SRC_URI="http://xrootd.org/download/v${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples fuse http kerberos python readline rbd ssl test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- !<sci-physics/root-5.32[xrootd]
- sys-libs/zlib
- fuse? ( sys-fs/fuse:= )
- kerberos? ( virtual/krb5 )
- python? ( ${PYTHON_DEPS} )
- rbd? ( sys-cluster/ceph )
- readline? ( sys-libs/readline:0= )
- ssl? ( dev-libs/openssl:0= )
-"
-DEPEND="${CDEPEND}
- doc? (
- app-doc/doxygen[dot]
- python? ( dev-python/sphinx )
- )
- test? ( dev-util/cppunit )
-"
-RDEPEND="${CDEPEND}
- dev-lang/perl
-"
-REQUIRED_USE="
- http? ( kerberos ssl )
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-PATCHES=(
- "${FILESDIR}"/xrootd-4.8.3-crc32.patch
- "${FILESDIR}"/${PN}-4.8.3-Werror_only_Debug.patch
-)
-
-# xrootd plugins are not intended to be linked with,
-# they are to be loaded at runtime by xrootd,
-# see https://github.com/xrootd/xrootd/issues/447
-QA_SONAME="/usr/lib.*/libXrd*-4.so"
-
-pkg_setup() {
- enewgroup xrootd
- enewuser xrootd -1 -1 "${EPREFIX}"/var/spool/xrootd xrootd
- use python && python_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_CEPH=$(usex rbd)
- -DENABLE_CRYPTO=$(usex ssl)
- -DENABLE_FUSE=$(usex fuse)
- -DENABLE_HTTP=$(usex http)
- -DENABLE_KRB5=$(usex kerberos)
- -DENABLE_PYTHON=$(usex python)
- -DENABLE_READLINE=$(usex readline)
- -DENABLE_TESTS=$(usex test)
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use doc; then
- doxygen Doxyfile || die
- if use python; then
- emake -C bindings/python/docs html
- fi
- fi
-}
-
-src_install() {
- use doc && HTML_DOCS=( doxydoc/html/. )
- dodoc docs/ReleaseNotes.txt
- cmake-utils_src_install
- find "${D}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
-
- # base configs
- insinto /etc/xrootd
- doins packaging/common/*.cfg
-
- fowners root:xrootd /etc/xrootd
- keepdir /var/log/xrootd
- fowners xrootd:xrootd /var/log/xrootd
-
- local i
- for i in cmsd frm_purged frm_xfrd xrootd; do
- newinitd "${FILESDIR}"/${i}.initd ${i}
- done
- # all daemons MUST use single master config file
- newconfd "${FILESDIR}"/xrootd.confd xrootd
-
- if use python; then
- python_optimize "${D}/$(python_get_sitedir)"
-
- if use doc; then
- docinto python
- docompress -x "/usr/share/doc/${PF}/python/html"
- dodoc -r bindings/python/docs/build/html
- fi
- if use examples; then
- docinto python
- dodoc -r bindings/python/examples
- fi
- fi
-}