summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libetpan/Manifest2
-rw-r--r--net-libs/libetpan/libetpan-1.1.ebuild81
-rw-r--r--net-libs/libetpan/libetpan-1.5.ebuild72
3 files changed, 0 insertions, 155 deletions
diff --git a/net-libs/libetpan/Manifest b/net-libs/libetpan/Manifest
index 3715216b810d..56296536fb30 100644
--- a/net-libs/libetpan/Manifest
+++ b/net-libs/libetpan/Manifest
@@ -1,4 +1,2 @@
-DIST libetpan-1.1.tar.gz 1657767 SHA256 ce3ac567d0f07e5b2d1fdb0045042a8295ec477cd933de1a391fd48139c1f75e SHA512 fbcaf0e467d6f7541148aa60e89e1275f3cdb2b1039b8e6eaeba476e4b4411f44acfc01936eb7c4ab92cc0a574f3dcc4836e57bdf38861008bed0d015211f82b WHIRLPOOL a8c714937d797f4e8cabb59edf2b5880723e0bc6d4947ac78a3bd31f7b2e94f36c6699f7186f527b1075460f65dbb10d7c083442b6646cba1dbf2de68dd7c291
-DIST libetpan-1.5.tar.gz 6139416 SHA256 42c4d858c3c1762c3e348889fbbf6cc5e5c5e654170d1df1ebb9c14aa4579736 SHA512 7b0a3adff7d7b3a7e3ea1d1a330ef6fea5ed86077a9ccf3fb5e51548d337c6c1f1fbb9ca81560b478335a9acf34e08bfef1895a05c5a69c37e3b87651c255fd5 WHIRLPOOL c408cbef9cc4e9bfec07a6e87a5afa96ea241770564c11f625776e4d692484c75ad01724c10923e38927d344616f4d396fa652d63d8cdcb2451d2a075dd0909e
DIST libetpan-1.6.tar.gz 6144117 SHA256 7962b1f9445be24d1eb72daddabaebb427074c14a50e9dad0cebdec044c71e17 SHA512 e3f19cfe231e8cadbb6cba3a765611e3aaeb260fa78e05cea1153a59015abe547c0f3a8b84c6b41cbbd17d04a4c7ab7b14d1b1b44a1a4b24ac124cb200a191a5 WHIRLPOOL b72a50513dbd55898e79b14a53088277b12ae7ac911ab0a9692d47f85dadd1b80a9ba616bd7a2beb89d9406940f4edf24cabf93aabef0cd27d6de6bef4e29a40
DIST libetpan-1.7.tar.gz 6184289 SHA256 47d0c049d8adcdcfd0698e9f1fcb85416b0b2f476eed1f52aae72c2883cf05b0 SHA512 b90c46f6692df7a7889be68f5712a6b6d58ef1931edb82674da2cb6690c2150c935ca782fd32c1567c31cdff629261bd1ba23921b12431d781a086729489573e WHIRLPOOL b6c286a0554ecf4ad3c0d09dd45d1892a665bdc4eed4e19b65745de3a6195351cccef51da6447f34d57a29dacd01bbb16067d30911b837db914016ddb7ab2e87
diff --git a/net-libs/libetpan/libetpan-1.1.ebuild b/net-libs/libetpan/libetpan-1.1.ebuild
deleted file mode 100644
index dfea485a1df0..000000000000
--- a/net-libs/libetpan/libetpan-1.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit autotools eutils
-
-DESCRIPTION="A portable, efficient middleware for different kinds of mail access"
-HOMEPAGE="http://libetpan.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="berkdb debug gnutls ipv6 liblockfile sasl ssl static-libs"
-
-DEPEND="berkdb? ( sys-libs/db )
- gnutls? ( net-libs/gnutls )
- !gnutls? ( ssl? ( dev-libs/openssl ) )
- sasl? ( dev-libs/cyrus-sasl )
- liblockfile? ( net-libs/liblockfile )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0-nonnull.patch
-
- sed -i \
- -e "s/-O2 -g//" \
- -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" \
- configure.ac
-
- eautoreconf
-}
-
-src_configure() {
- local sslconf
-
- if use ssl; then
- if use gnutls; then
- sslconf="--with-gnutls --without-openssl"
- else
- sslconf="--without-gnutls --with-openssl"
- fi
- else
- if use gnutls; then
- sslconf="--with-gnutls --without-openssl"
- else
- sslconf="--without-gnutls --without-openssl"
- fi
- fi
-
- # in Prefix emake uses SHELL=${BASH}, export CONFIG_SHELL to the same so
- # libtool recognises it as valid shell (bug #300211)
- use prefix && export CONFIG_SHELL=${BASH}
- # The configure script contains an error, in that it doesn't check the
- # argument of --enable-{debug,optim}, hence --disable-debug results in
- # --enable-debug=no, which isn't checked and debugging flags are blindly
- # injected. So, avoid passing --disable-debug when we don't need it.
- econf \
- $(use debug && echo --enable-debug) \
- $(use_enable berkdb db) \
- $(use_with sasl) \
- $(use_enable ipv6) \
- $(use_enable liblockfile lockfile) \
- $(use_enable static-libs static) \
- ${sslconf}
-}
-
-src_install() {
- default
- use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
-}
-
-pkg_postinst() {
- echo
- ewarn "The soname for libetpan has changed after libetpan-1.1."
- ewarn "If you have upgraded from that or earlier version, it is recommended to run"
- ewarn "revdep-rebuild to fix any linking errors caused by this change."
- echo
-}
diff --git a/net-libs/libetpan/libetpan-1.5.ebuild b/net-libs/libetpan/libetpan-1.5.ebuild
deleted file mode 100644
index 0b90ba5c872c..000000000000
--- a/net-libs/libetpan/libetpan-1.5.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit autotools eutils
-
-DESCRIPTION="A portable, efficient middleware for different kinds of mail access"
-HOMEPAGE="http://libetpan.sourceforge.net/"
-SRC_URI="https://github.com/dinhviethoa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="berkdb debug gnutls ipv6 liblockfile sasl ssl static-libs"
-
-DEPEND="berkdb? ( sys-libs/db )
- gnutls? ( net-libs/gnutls )
- !gnutls? ( ssl? ( dev-libs/openssl ) )
- sasl? ( dev-libs/cyrus-sasl )
- liblockfile? ( net-libs/liblockfile )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0-nonnull.patch
-
- sed -i \
- -e "s/-O2 -g//" \
- -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" \
- configure.ac
-
- eautoreconf
-}
-
-src_configure() {
- local sslconf
-
- if use ssl; then
- if use gnutls; then
- sslconf="--with-gnutls --without-openssl"
- else
- sslconf="--without-gnutls --with-openssl"
- fi
- else
- if use gnutls; then
- sslconf="--with-gnutls --without-openssl"
- else
- sslconf="--without-gnutls --without-openssl"
- fi
- fi
-
- # in Prefix emake uses SHELL=${BASH}, export CONFIG_SHELL to the same so
- # libtool recognises it as valid shell (bug #300211)
- use prefix && export CONFIG_SHELL=${BASH}
- # The configure script contains an error, in that it doesn't check the
- # argument of --enable-{debug,optim}, hence --disable-debug results in
- # --enable-debug=no, which isn't checked and debugging flags are blindly
- # injected. So, avoid passing --disable-debug when we don't need it.
- econf \
- $(use debug && echo --enable-debug) \
- $(use_enable berkdb db) \
- $(use_with sasl) \
- $(use_enable ipv6) \
- $(use_enable liblockfile lockfile) \
- $(use_enable static-libs static) \
- ${sslconf}
-}
-
-src_install() {
- default
- use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
-}