summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh2/Manifest1
-rw-r--r--net-libs/libssh2/libssh2-1.8.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libssh2/Manifest b/net-libs/libssh2/Manifest
index 50610673093f..a8d08b3dcd32 100644
--- a/net-libs/libssh2/Manifest
+++ b/net-libs/libssh2/Manifest
@@ -1 +1,2 @@
DIST libssh2-1.7.0.tar.gz 811714 SHA256 e4561fd43a50539a8c2ceb37841691baf03ecb7daf043766da1b112e4280d584 SHA512 0f9dfd83196129568c00383e2e4fea29b3d8c4f3b1690f550a6748d1db68cc437b4ed083f5d3d4646365fdc839819619aea96eeaef5ab072c7023d13f08b5153 WHIRLPOOL dceefdc11b6b88f4320bfdd01044dc9c81e4d1e3e54a9e2ec8f6869ba091668e5957a3e2a56934196c87f1877d61ebe0b45f450ca12bf1802da9812db8a4ffb6
+DIST libssh2-1.8.0.tar.gz 854916 SHA256 39f34e2f6835f4b992cafe8625073a88e5a28ba78f83e8099610a7b3af4676d4 SHA512 289aa45c4f99653bebf5f99565fe9c519abc204feb2084b47b7cc3badc8bf4ecdedd49ea6acdce8eb902b3c00995d5f92a3ca77b2508b92f04ae0e7de7287558 WHIRLPOOL 2f9523214b6aa48842e4bc23a8e8edb62ddbe438a18db2269bcb802c1e9234c02fece51e0530f949adad1aedef3062c0a8d959734b54cbf8ae372766a5f91c4d
diff --git a/net-libs/libssh2/libssh2-1.8.0.ebuild b/net-libs/libssh2/libssh2-1.8.0.ebuild
new file mode 100644
index 000000000000..023e8a375c63
--- /dev/null
+++ b/net-libs/libssh2/libssh2-1.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+inherit autotools-multilib
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI="http://www.${PN}.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="gcrypt libressl static-libs test zlib"
+
+DEPEND="
+ !gcrypt? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ )
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+DOCS=(
+ README
+)
+
+src_prepare() {
+ sed -i -e 's|mansyntax.sh||g' tests/Makefile.am || die
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ # Disable tests that require extra permissions (bug #333319)
+ use test && local -x ac_cv_path_SSHD=
+
+ local myeconfargs=(
+ $(use_with zlib libz)
+ $(usex gcrypt --with-libgcrypt --with-openssl)
+ )
+ autotools-utils_src_configure
+}