summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libasyncns/libasyncns-0.8-r4.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-libs/libasyncns/libasyncns-0.8-r4.ebuild b/net-libs/libasyncns/libasyncns-0.8-r4.ebuild
index 4d10bdbdf781..cdde64a4fc83 100644
--- a/net-libs/libasyncns/libasyncns-0.8-r4.ebuild
+++ b/net-libs/libasyncns/libasyncns-0.8-r4.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools flag-o-matic multilib-minimal
DESCRIPTION="C library for executing name service queries asynchronously"
@@ -15,8 +16,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd
IUSE="doc debug"
-RDEPEND=""
-DEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="doc? ( app-doc/doxygen )"
src_prepare() {
default
@@ -48,11 +48,11 @@ multilib_src_compile() {
}
multilib_src_install() {
- emake DESTDIR="${D}" install
+ default
if multilib_is_native_abi && use doc; then
docinto apidocs
- dohtml html/*
+ dodoc -r html
fi
}