summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/asmail/files/asmail-2.1-ldflags.patch')
-rw-r--r--net-mail/asmail/files/asmail-2.1-ldflags.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/net-mail/asmail/files/asmail-2.1-ldflags.patch b/net-mail/asmail/files/asmail-2.1-ldflags.patch
new file mode 100644
index 000000000000..14d431c6da4b
--- /dev/null
+++ b/net-mail/asmail/files/asmail-2.1-ldflags.patch
@@ -0,0 +1,19 @@
+commit 89ac271856ad5ecc7bd38c5aabc393b41976aca2
+Author: Eray Aslan <eras@gentoo.org>
+Date: Tue Jun 7 18:11:43 2011 +0300
+
+ Respect LDFLAGS
+
+diff --git a/autoconf/Makefile.common.in b/autoconf/Makefile.common.in
+index de290d0..cebe471 100644
+--- a/autoconf/Makefile.common.in
++++ b/autoconf/Makefile.common.in
+@@ -49,7 +49,7 @@ indent:
+ done
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
++ $(CC) $(LDFLAGS) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
+
+ .c.o:
+ $(CC) $(CCFLAGS) $(EXTRA_DEFINES) $(INCLUDES) $(EXTRA_INCLUDES) -c $*.c