summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/courierpassd/courierpassd-1.1.2.ebuild')
-rw-r--r--net-mail/courierpassd/courierpassd-1.1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-mail/courierpassd/courierpassd-1.1.2.ebuild b/net-mail/courierpassd/courierpassd-1.1.2.ebuild
new file mode 100644
index 000000000000..53502adf54df
--- /dev/null
+++ b/net-mail/courierpassd/courierpassd-1.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+DESCRIPTION="Courierpassd is a utility for changing a user's password from across a network"
+HOMEPAGE="http://www.arda.homeunix.net/"
+SRC_URI="http://www.arda.homeunix.net/store/${P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="xinetd"
+
+DEPEND="net-libs/courier-authlib
+ xinetd? ( sys-apps/xinetd )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ doins "${FILESDIR}/courierpassd" || die "doins failed"
+ fi
+
+ dodoc README AUTHORS ChangeLog NEWS || die "dodoc failed"
+}