summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/fdm/files/fdm-2.2-configure-strlcpy.patch')
-rw-r--r--net-mail/fdm/files/fdm-2.2-configure-strlcpy.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-mail/fdm/files/fdm-2.2-configure-strlcpy.patch b/net-mail/fdm/files/fdm-2.2-configure-strlcpy.patch
new file mode 100644
index 000000000000..443a7240c40a
--- /dev/null
+++ b/net-mail/fdm/files/fdm-2.2-configure-strlcpy.patch
@@ -0,0 +1,20 @@
+diff --git a/configure.ac b/configure.ac
+index e356e9c..d91ae66 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -124,13 +124,13 @@ if test "x$found_libssl" = xno; then
+ AC_MSG_ERROR("libssl not found")
+ fi
+
+-AC_CHECK_DECL(strlcpy, found_strlcpy=yes, found_strlcpy=no)
++AC_CHECK_FUNC(strlcpy, found_strlcpy=yes, found_strlcpy=no)
+ if test "x$found_strlcpy" = xyes; then
+ AC_DEFINE(HAVE_STRLCPY)
+ fi
+ AM_CONDITIONAL(NO_STRLCPY, [test "x$found_strlcpy" = xno])
+
+-AC_CHECK_DECL(strlcat, found_strlcat=yes, found_strlcat=no)
++AC_CHECK_FUNC(strlcat, found_strlcat=yes, found_strlcat=no)
+ if test "x$found_strlcat" = xyes; then
+ AC_DEFINE(HAVE_STRLCAT)
+ fi