summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mairix')
-rw-r--r--net-mail/mairix/Manifest2
-rw-r--r--net-mail/mairix/mairix-0.23.ebuild50
-rw-r--r--net-mail/mairix/metadata.xml12
3 files changed, 64 insertions, 0 deletions
diff --git a/net-mail/mairix/Manifest b/net-mail/mairix/Manifest
new file mode 100644
index 000000000000..4ae7120ab7e4
--- /dev/null
+++ b/net-mail/mairix/Manifest
@@ -0,0 +1,2 @@
+DIST mairix-0.23-gnus-marks-propagation.patch.gz 3401 SHA256 2b6be6041616c86d26f1c3fc6db969668b852042ccd859dad4e2c1bb5ade420e
+DIST mairix-0.23.tar.gz 193726 SHA256 804e235b183c3350071a28cdda8eb465bcf447092a8206f40486191875bdf2fb
diff --git a/net-mail/mairix/mairix-0.23.ebuild b/net-mail/mairix/mairix-0.23.ebuild
new file mode 100644
index 000000000000..9d8891a0f700
--- /dev/null
+++ b/net-mail/mairix/mairix-0.23.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Indexes and searches Maildir/MH folders"
+HOMEPAGE="http://www.rpcurnow.force9.co.uk/mairix/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ gnus? ( mirror://gentoo/${P}-gnus-marks-propagation.patch.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-macos"
+
+IUSE="zlib bzip2 gnus"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ bzip2? ( app-arch/bzip2 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+# Fail on various locales
+RESTRICT="test"
+
+src_prepare() {
+ # econf would fail with unknown options.
+ # Now it only prints "Unrecognized option".
+ sed -i -e "/^[[:space:]]*bad_options=yes/d" "${S}"/configure || die "sed failed"
+
+ # Add support for gnus marks propagation (bug #274578)
+ use gnus && epatch "${WORKDIR}"/${P}-gnus-marks-propagation.patch
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable zlib gzip-mbox) \
+ $(use_enable bzip2 bzip-mbox)
+}
+
+src_install() {
+ dobin mairix
+ doman mairix.1 mairixrc.5
+ dodoc NEWS README dotmairixrc.eg
+}
diff --git a/net-mail/mairix/metadata.xml b/net-mail/mairix/metadata.xml
new file mode 100644
index 000000000000..e360c5c07b57
--- /dev/null
+++ b/net-mail/mairix/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <use>
+ <flag name="gnus">Add support for the marks propagation feature in
+ <pkg>app-emacs/gnus</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">mairix</remote-id>
+ </upstream>
+</pkgmetadata>