summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mu')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/metadata.xml3
-rw-r--r--net-mail/mu/mu-1.3.6.ebuild99
3 files changed, 102 insertions, 1 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index 81283ede139d..a531312011d3 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,3 +1,4 @@
DIST mu-0.9.18.tar.gz 2250319 BLAKE2B 7eb83a797eccff706ac6b264a7d56feae80e40f370e190e0a94f2524dd73a8bfdb35599909f90d0a2b87fc513bbcf2b00fa307a3e4d0b6718ebdc7f7fcdc6df0 SHA512 47104d18547de0871782abc4e1c6dbf1f9b2489410e5716043861bf8d973d33d2138de7d7ac568b300ca86ae9f1a0fda0fa9555ad9a5938771336ef958183546
DIST mu-1.0.tar.gz 2273670 BLAKE2B a771b00159142fa4a671d07cf9de6f0f941c432ddee31f19606c260ba3dfef857a36a333f5ede4ca30be88d7b7eae28e996e15a8deebd96971b341f0f72bfbbb SHA512 49b0b86f22e9a6ace1fc3fd6e7a8a523aa9edf092b953d59f59a1ef7311c8c546a261a1a186e3285cea788be20c816c70ac08d1514f700ff97258a2012ad394d
DIST mu-1.3.5.tar.gz 2305222 BLAKE2B ff6025cf053d7c2880855ec32953a2881ce8bc7d468082f13e45e7684dd41bd7906cbc9a619fd27bd4860bb953e4a547c3d22ea9a7fb4c645825c755ee33b5f9 SHA512 5d7eccec296affbe6e2e31d2204672f8ecac43f1a0c93673f983378fcf7ad8a050662097ec58603251eed31b499054d6c453a2a4e2c70dfdd896c430559b95c0
+DIST mu-1.3.6.tar.gz 2305653 BLAKE2B b9a556c1b374e0b72b6b0c40beba581dc3fe0e0a654a881db3a47582481ef00831e18bcd771e24b231ef843e97f14f7401ad8d041c077617b865f1fa971d1a0f SHA512 c889dc3fc1b7f1333f2adc3891f23ea8977c77ac6af532fec37c6570b4fbb2ce8dda0776568d61dedfa34f0519bb5bba89b90002503c3191a0d633ecfb9d5c87
diff --git a/net-mail/mu/metadata.xml b/net-mail/mu/metadata.xml
index 52409e491151..9d458cfbe1a6 100644
--- a/net-mail/mu/metadata.xml
+++ b/net-mail/mu/metadata.xml
@@ -14,7 +14,8 @@
are looking for, assuming that you store your e-mails in Maildirs. It also includes an emacs based mail client mu4e.
</longdescription>
<use>
- <flag name="emacs">Install the mu4e mail client.</flag>
+ <flag name="emacs">Install the mu4e mail client</flag>
+ <flag name="mug">Install the mug toy client, not for normal use</flag>
</use>
<upstream>
<remote-id type="google-code">mu0</remote-id>
diff --git a/net-mail/mu/mu-1.3.6.ebuild b/net-mail/mu/mu-1.3.6.ebuild
new file mode 100644
index 000000000000..d6bea16eed27
--- /dev/null
+++ b/net-mail/mu/mu-1.3.6.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="http://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs guile mug"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4
+ emacs? ( >=app-editors/emacs-24.4:* )
+ guile? ( >=dev-scheme/guile-2.0 )
+ mug? (
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ )"
+# net-mail/mailutils also installes /usr/bin/mu. Block it until somebody
+# really wants both installed at the same time.
+RDEPEND="
+ ${DEPEND}
+ !net-mail/mailutils"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="70mu-gentoo.el"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable emacs mu4e)
+ $(use_enable mug gtk)
+ $(use_enable mug webkit)
+ $(use_enable guile)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ dobin mu/mu
+ dodoc AUTHORS HACKING NEWS NEWS.org TODO README README.org ChangeLog
+ if use emacs; then
+ elisp-install ${PN} mu4e/*.el mu4e/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo mu4e/mu4e.info
+ fi
+
+ doman man/mu-add.1 man/mu-bookmarks.5 man/mu-cfind.1 man/mu-easy.1 \
+ man/mu-extract.1 man/mu-find.1 man/mu-help.1 man/mu-index.1 \
+ man/mu-mkdir.1 man/mu-query.7 man/mu-remove.1 \
+ man/mu-script.1 man/mu-server.1 man/mu-verify.1 \
+ man/mu-view.1 man/mu.1
+
+ if use guile; then
+ doinfo guile/mu-guile.info
+ fi
+
+ if use mug; then
+ dobin toys/mug/mug
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "http://www.djcbsoftware.nl/code/mu/mu4e/"
+ fi
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}