summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/bgpq/bgpq-1.0.9.9.ebuild')
-rw-r--r--net-misc/bgpq/bgpq-1.0.9.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/bgpq/bgpq-1.0.9.9.ebuild b/net-misc/bgpq/bgpq-1.0.9.9.ebuild
new file mode 100644
index 000000000000..1e514b22ffa9
--- /dev/null
+++ b/net-misc/bgpq/bgpq-1.0.9.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Generate access-lists for Cisco/Juniper routers"
+HOMEPAGE="http://www.lexa.ru/snar/bgpq.html"
+SRC_URI="http://snar.spb.ru/prog/bgpq/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-devel/flex"
+RDEPEND=""
+
+src_prepare() {
+ # Respect CFLAGS and LDFLAGS
+ sed -i \
+ -e '/^CFLAGS+=/s/+=-g /=/' \
+ -e '/^LDADD/s/@LIBS@/@LDFLAGS@ @LIBS@/' \
+ Makefile.in || die 'sed on Makefile.in failed'
+
+ epatch_user
+}
+
+src_install() {
+ dobin bgpq
+ doman bgpq.8
+ dodoc CHANGES
+ dohtml *.html
+}