summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild')
-rw-r--r--net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild b/net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild
new file mode 100644
index 000000000000..5757f718f4d5
--- /dev/null
+++ b/net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Effectively suppresses illegal DHCP servers on the LAN"
+HOMEPAGE="http://www.netpatch.ru/dhcdrop.html"
+SRC_URI="http://www.netpatch.ru/projects/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+IUSE="static"
+
+RDEPEND="!static? ( net-libs/libpcap )"
+DEPEND="static? ( net-libs/libpcap[static-libs] )
+ ${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README )
+
+src_prepare() {
+ # Fix building with clang, bug #731694
+ sed -i \
+ -e '/^PACKAGE_/s/"//g' \
+ configure || die
+
+ eapply_user
+}
+
+src_configure() {
+ econf $(use static && echo "--enable-static-build")
+}