summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/grive/grive-0.5.1_pre20160114.ebuild')
-rw-r--r--net-misc/grive/grive-0.5.1_pre20160114.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/grive/grive-0.5.1_pre20160114.ebuild b/net-misc/grive/grive-0.5.1_pre20160114.ebuild
new file mode 100644
index 000000000000..44a011e91973
--- /dev/null
+++ b/net-misc/grive/grive-0.5.1_pre20160114.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/vitalif/${PN}2.git"
+else
+ inherit vcs-snapshot
+ COMMIT="cfb8ff08b300d1fa57e12cdc85f724e3e25c906d"
+ SRC_URI="https://github.com/vitalif/${PN}2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An open source Linux client for Google Drive"
+HOMEPAGE="https://github.com/vitalif/grive2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/expat
+ >=dev-libs/json-c-0.11-r1:=
+ dev-libs/libgcrypt:0=
+ net-misc/curl
+ sys-libs/binutils-libs:0=
+ sys-libs/glibc
+ dev-libs/yajl
+"
+DEPEND="${RDEPEND}"