summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/mosh/mosh-1.2.4.ebuild')
-rw-r--r--net-misc/mosh/mosh-1.2.4.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/net-misc/mosh/mosh-1.2.4.ebuild b/net-misc/mosh/mosh-1.2.4.ebuild
deleted file mode 100644
index 2509942ee26e..000000000000
--- a/net-misc/mosh/mosh-1.2.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit autotools bash-completion-r1 vcs-snapshot
-
-DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
-HOMEPAGE="http://mosh.mit.edu"
-SRC_URI="http://mosh.mit.edu/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~mips ppc x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos"
-IUSE="+client examples +mosh-hardening +server ufw +utempter"
-REQUIRED_USE="|| ( client server )
- examples? ( client )"
-
-RDEPEND="dev-libs/protobuf
- sys-libs/ncurses:0
- virtual/ssh
- client? ( dev-lang/perl
- dev-perl/IO-Tty )
- utempter? ( sys-libs/libutempter )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-completion \
- $(use_enable client) \
- $(use_enable server) \
- $(use_enable examples) \
- $(use_enable ufw) \
- $(use_enable mosh-hardening hardening) \
- $(use_with utempter)
-}
-
-src_compile() {
- emake V=1
-}
-
-src_install() {
- default
-
- for myprog in $(find src/examples -type f -perm /0111) ; do
- newbin ${myprog} ${PN}-$(basename ${myprog})
- elog "${myprog} installed as ${PN}-$(basename ${myprog})"
- done
-
- # bug 477384
- dobashcomp conf/bash_completion.d/mosh
-}