summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openntpd')
-rw-r--r--net-misc/openntpd/metadata.xml1
-rw-r--r--net-misc/openntpd/openntpd-6.2_p3-r2.ebuild10
-rw-r--r--net-misc/openntpd/openntpd-6.8_p1-r1.ebuild7
-rw-r--r--net-misc/openntpd/openntpd-6.8_p1.ebuild13
4 files changed, 11 insertions, 20 deletions
diff --git a/net-misc/openntpd/metadata.xml b/net-misc/openntpd/metadata.xml
index 8cf4c9d357c8..b87fa42aa955 100644
--- a/net-misc/openntpd/metadata.xml
+++ b/net-misc/openntpd/metadata.xml
@@ -17,6 +17,5 @@
</longdescription>
<use>
<flag name="constraints">Enable HTTPS TLS time constraint support</flag>
- <flag name="libressl">Enable HTTPS TLS time constraint support using <pkg>dev-libs/libressl</pkg></flag>
</use>
</pkgmetadata>
diff --git a/net-misc/openntpd/openntpd-6.2_p3-r2.ebuild b/net-misc/openntpd/openntpd-6.2_p3-r2.ebuild
index 8f65c14883e6..4d7fc203e169 100644
--- a/net-misc/openntpd/openntpd-6.2_p3-r2.ebuild
+++ b/net-misc/openntpd/openntpd-6.2_p3-r2.ebuild
@@ -14,11 +14,10 @@ SRC_URI="mirror://openbsd/OpenNTPD/${MY_P}.tar.gz"
LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
-IUSE="libressl selinux"
+IUSE="selinux"
DEPEND="
- !net-misc/ntp[-openntpd]
- libressl? ( dev-libs/libressl:0= )"
+ !net-misc/ntp[-openntpd]"
RDEPEND="
${DEPEND}
@@ -47,15 +46,14 @@ src_prepare() {
sed -i 's:servers pool.ntp.org:#servers pool.ntp.org:' ntpd.conf || die
printf "\n# Choose servers announced from Gentoo NTP Pool\nservers 0.gentoo.pool.ntp.org\nservers 1.gentoo.pool.ntp.org\nservers 2.gentoo.pool.ntp.org\nservers 3.gentoo.pool.ntp.org\n" >> ntpd.conf || die
- # disable constraint config if libressl not enabled
- use libressl || sed -ie 's/^constraints/#constraints/g' ntpd.conf || die
+ sed -ie 's/^constraints/#constraints/g' ntpd.conf || die
}
src_configure() {
econf \
--with-privsep-user=openntpd \
--with-privsep-path=/var/lib/openntpd/chroot \
- $(use_enable libressl https-constraint)
+ --disable-https-constraint
}
src_install() {
diff --git a/net-misc/openntpd/openntpd-6.8_p1-r1.ebuild b/net-misc/openntpd/openntpd-6.8_p1-r1.ebuild
index 49bc5ddd4cc9..a600e51c8b82 100644
--- a/net-misc/openntpd/openntpd-6.8_p1-r1.ebuild
+++ b/net-misc/openntpd/openntpd-6.8_p1-r1.ebuild
@@ -14,14 +14,11 @@ SRC_URI="mirror://openbsd/OpenNTPD/${MY_P}.tar.gz"
LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="constraints libressl selinux"
+IUSE="constraints selinux"
DEPEND="
!net-misc/ntp[-openntpd]
- constraints? (
- libressl? ( dev-libs/libressl:= )
- !libressl? ( dev-libs/libretls:= )
- )"
+ constraints? ( dev-libs/libretls:= )"
RDEPEND="
${DEPEND}
diff --git a/net-misc/openntpd/openntpd-6.8_p1.ebuild b/net-misc/openntpd/openntpd-6.8_p1.ebuild
index ce6e6c788913..ee0f69ce5392 100644
--- a/net-misc/openntpd/openntpd-6.8_p1.ebuild
+++ b/net-misc/openntpd/openntpd-6.8_p1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,12 +14,10 @@ SRC_URI="mirror://openbsd/OpenNTPD/${MY_P}.tar.gz"
LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="libressl selinux"
+IUSE="selinux"
DEPEND="
- !net-misc/ntp[-openntpd]
- libressl? ( dev-libs/libressl:0= )"
-
+ !net-misc/ntp[-openntpd]"
RDEPEND="
${DEPEND}
acct-group/openntpd
@@ -43,14 +41,13 @@ src_prepare() {
sed -i 's:^server:#server:g' ntpd.conf || die
printf "\n# Choose servers announced from Gentoo NTP Pool\nservers 0.gentoo.pool.ntp.org\nservers 1.gentoo.pool.ntp.org\nservers 2.gentoo.pool.ntp.org\nservers 3.gentoo.pool.ntp.org\n" >> ntpd.conf || die
- # disable constraint config if libressl not enabled
- use libressl || sed -ie 's/^constraints/#constraints/g' ntpd.conf || die
+ sed -ie 's/^constraints/#constraints/g' ntpd.conf || die
}
src_configure() {
econf \
--with-privsep-user=openntpd \
- $(use_enable libressl https-constraint)
+ --disable-https-constraint
}
src_install() {