summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/packETH/packETH-1.7.3.ebuild')
-rw-r--r--net-misc/packETH/packETH-1.7.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/packETH/packETH-1.7.3.ebuild b/net-misc/packETH/packETH-1.7.3.ebuild
new file mode 100644
index 000000000000..522484707aab
--- /dev/null
+++ b/net-misc/packETH/packETH-1.7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Packet generator tool for ethernet"
+HOMEPAGE="http://packeth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/packeth/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+DOCS=( AUTHORS CHANGELOG README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libs-and-flags.patch
+ eautoreconf
+}