summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pcapfix')
-rw-r--r--net-misc/pcapfix/Manifest4
-rw-r--r--net-misc/pcapfix/files/pcapfix-1.1.7-respect-CFLAGS.patch21
-rw-r--r--net-misc/pcapfix/metadata.xml2
-rw-r--r--net-misc/pcapfix/pcapfix-0.7.ebuild26
-rw-r--r--net-misc/pcapfix/pcapfix-1.1.4.ebuild27
-rw-r--r--net-misc/pcapfix/pcapfix-1.1.7.ebuild41
6 files changed, 65 insertions, 56 deletions
diff --git a/net-misc/pcapfix/Manifest b/net-misc/pcapfix/Manifest
index d74002f56dee..606bb40cbba3 100644
--- a/net-misc/pcapfix/Manifest
+++ b/net-misc/pcapfix/Manifest
@@ -1,2 +1,2 @@
-DIST pcapfix-0.7.tar.gz 25753 BLAKE2B 75a8bca8e5c0f7b6604a9c2202116f3fd18917bb98797b401618d32861a14e2bc7f7a1fe684d2e057c4314de72bbbb825dc3142ea93bd8dea0b1bc4716e240e0 SHA512 254eb5803bbcff4249f20af4cd1afa5b300eefb3448e3650899fa94329f38e298e4e7b1033836aa04434b1eadc67611204e3f67d41917c761d5cba424d789298
-DIST pcapfix-1.1.4.tar.gz 52184 BLAKE2B 4def04cebc9144af86d43c28892575627ed98bf14fa99e5e4fe5181a406871ceeac1f431c73d90daae151bb8b6e5315e8bc47c430d2ed55f9e0c3de1decbe0e9 SHA512 6203e9032d2f24fe5d4aaefd9cfd57ece97a318af3ecd8da7171307a59c2a10b2e92206d5cf96e2dd9bfafc239dd9bc95a224bf5fef9e0c0432a6e76ff10d1da
+DIST pcapfix-1.1.7-musl-stdint.patch.bz2 2084 BLAKE2B 2dafe8597f247c1b403e89552403850f10e9a0149a74d092a9187510a997b6339af831ea6f3b01d7ab04367a966828aedc665b517e7108fea9b6d3607815d531 SHA512 5e6d197d6bda6bd10525066a46dc301ae7b92a2a0d9062e3dcef22730b27b12d1b8cd1e58e344f6b4a7bd5b0dfe1351bf868489285bf1651f8aa96f0014b3adf
+DIST pcapfix-1.1.7.tar.gz 54784 BLAKE2B c688b3eabf04ff4baf88170c5868edd2b504779a9550ce6a2ca8b4839310b75a26c7e6ae6afc82cf763f19f8ffebe357c730b0ea1bd4b05ed071e78ad6c9f6e5 SHA512 d8d1106349116303f35254f680916f1ea26b163f9afceb5d237eed89880810d4b7b40ebca9de58ec95af2336dd78f4e11af1a08b89f6765055843a9791c156bd
diff --git a/net-misc/pcapfix/files/pcapfix-1.1.7-respect-CFLAGS.patch b/net-misc/pcapfix/files/pcapfix-1.1.7-respect-CFLAGS.patch
new file mode 100644
index 000000000000..a80419b1a87b
--- /dev/null
+++ b/net-misc/pcapfix/files/pcapfix-1.1.7-respect-CFLAGS.patch
@@ -0,0 +1,21 @@
+https://github.com/Rup0rt/pcapfix/pull/27
+
+From: Sam James <sam@gentoo.org>
+Date: Wed, 29 Dec 2021 06:48:09 +0000
+Subject: [PATCH] build: respect CFLAGS
+
+Allow overriding in the environment by using our value
+as just a default.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/Makefile
++++ b/Makefile
+@@ -6,7 +6,7 @@ MANDIR ?= $(PREFIX)/share/man
+ OPTFLAGS = $(shell getconf LFS_CFLAGS) -D_FORTIFY_SOURCE=2 -O2 -fstack-protector --param=ssp-buffer-size=4
+ WARNFLAGS = -Wall -Wextra -std=gnu99 -pedantic -Wformat -Werror=format-security
+ DEBUGFLAGS = -g
+-CFLAGS += $(OPTFLAGS) $(WARNFLAGS) $(DEBUGFLAGS)
++CFLAGS ?= $(OPTFLAGS) $(WARNFLAGS) $(DEBUGFLAGS)
+
+ # Determine extra LDFLAGS
+ OS := $(shell uname)
diff --git a/net-misc/pcapfix/metadata.xml b/net-misc/pcapfix/metadata.xml
index 79d462e85571..aaab041e8885 100644
--- a/net-misc/pcapfix/metadata.xml
+++ b/net-misc/pcapfix/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>robbat2@gentoo.org</email>
diff --git a/net-misc/pcapfix/pcapfix-0.7.ebuild b/net-misc/pcapfix/pcapfix-0.7.ebuild
deleted file mode 100644
index a0ef34d64263..000000000000
--- a/net-misc/pcapfix/pcapfix-0.7.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-DESCRIPTION="Repair and fix broken pcap files"
-HOMEPAGE="http://f00l.de/pcapfix/"
-SRC_URI="http://f00l.de/pcapfix/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- sed -e 's/gcc/$(CC) $(CFLAGS)/g' -i Makefile
-}
-
-src_install() {
- doman pcapfix.1
- dobin pcapfix
- dodoc README TODO Changelog
-}
diff --git a/net-misc/pcapfix/pcapfix-1.1.4.ebuild b/net-misc/pcapfix/pcapfix-1.1.4.ebuild
deleted file mode 100644
index 9f2ecbc9c679..000000000000
--- a/net-misc/pcapfix/pcapfix-1.1.4.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Repair and fix broken pcap files"
-HOMEPAGE="http://f00l.de/pcapfix/"
-SRC_URI="http://f00l.de/pcapfix/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-DOCS=( Changelog README )
-
-src_prepare() {
- default
- sed -e 's/gcc/$(CC) $(CFLAGS)/g' -i Makefile || die
- use debug || sed -e 's/DEBUGFLAGS = -g/DEBUGFLAGS =/g' -i Makefile || die
-}
-
-src_install() {
- doman pcapfix.1
- dobin pcapfix
- einstalldocs
-}
diff --git a/net-misc/pcapfix/pcapfix-1.1.7.ebuild b/net-misc/pcapfix/pcapfix-1.1.7.ebuild
new file mode 100644
index 000000000000..71f00b4ceb75
--- /dev/null
+++ b/net-misc/pcapfix/pcapfix-1.1.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Repair and fix broken pcap files"
+HOMEPAGE="https://f00l.de/pcapfix/"
+SRC_URI="https://f00l.de/pcapfix/${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-1.1.7-musl-stdint.patch.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DOCS=( Changelog README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.7-respect-CFLAGS.patch
+ "${WORKDIR}"/${PN}-1.1.7-musl-stdint.patch
+)
+
+src_prepare() {
+ default
+
+ use debug || sed -e 's/DEBUGFLAGS = -g/DEBUGFLAGS =/g' -i Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+
+ append-lfs-flags
+}
+
+src_install() {
+ doman pcapfix.1
+ dobin pcapfix
+ einstalldocs
+}