summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/proxyper/proxyper-341a.ebuild')
-rw-r--r--net-misc/proxyper/proxyper-341a.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/proxyper/proxyper-341a.ebuild b/net-misc/proxyper/proxyper-341a.ebuild
new file mode 100644
index 000000000000..f01d3a4653d1
--- /dev/null
+++ b/net-misc/proxyper/proxyper-341a.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="distributed.net personal proxy"
+HOMEPAGE="http://www.distributed.net"
+SRC_URI="http://http.distributed.net/pub/dcti/${PN}/${PN}${PV}-linux-x86-uclibc.tar.gz"
+LICENSE="distributed.net GPL-2"
+SLOT="0"
+KEYWORDS="-alpha -ppc -sparc x86"
+IUSE=""
+DEPEND=""
+RDEPEND="net-dns/host"
+
+S=${WORKDIR}/${PN}${PV}-linux-x86-uclibc
+
+RESTRICT="mirror"
+
+QA_PRESTRIPPED="opt/proxyper/proxyper"
+
+src_install() {
+ local DESTDIR=/opt/proxyper
+ exeinto ${DESTDIR}
+ doexe proxyper || die
+
+ # don't clobber an already existing ini file!
+ insinto ${DESTDIR}
+ if [ ! -f ${DESTDIR}/proxyper.ini ]
+ then
+ doins proxyper.ini || die
+ else
+ newins ${DESTDIR}/proxyper.ini proxyper.ini || die
+ fi
+
+ dodoc ChangeLog.txt
+ dohtml manual.html
+
+ newinitd "${FILESDIR}"/proxyper.init proxyper
+}
+
+pkg_postinst() {
+ einfo "Don't forget to modify the config file"
+ einfo "located in /opt/proxyper/proxyper.ini"
+ einfo "It's recommend to reading the manual first :-)"
+}
+
+pkg_postrm() {
+ local DESTDIR="/opt/proxyper"
+ if [ -d ${DESTDIR} ]; then
+ einfo "All files have not been removed from ${DESTDIR}"
+ fi
+}