summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/r8168')
-rw-r--r--net-misc/r8168/Manifest1
-rw-r--r--net-misc/r8168/r8168-8.047.01.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/r8168/Manifest b/net-misc/r8168/Manifest
index eae877f341af..c1877b985cb7 100644
--- a/net-misc/r8168/Manifest
+++ b/net-misc/r8168/Manifest
@@ -1 +1,2 @@
DIST r8168-8.045.08.tar.bz2 104427 BLAKE2B 56e332b518aa3c244750310a77d53ca2fc9a365f4a043e452c5593bcfcd5679c882d35b9977438ddb6a42ba40bb7c9b45e73926fda37c372314d57290ea3ffab SHA512 9037527f193d59da8bcf69396582e13acb58880ce52328e596ffb469352d38649d43f3c31b01ed607773bba1624561f299b3909dd6124448ed75e8f548d80563
+DIST r8168-8.047.01.tar.bz2 108629 BLAKE2B 35f92226726f5310edee0d0c62e5a257dd5963394ab0c0b1ce542efed3ac3b5788387f262f1426f1bc75e6bb1eb1d23a79e2b2114d0a5a60a6beb58844e2e318 SHA512 88957fb8dcfff123331b69319f4d719e6550a0a581a1079fd216c0ab346ee1bec8c3a1197c2daf9b0454f614f458606a597f0635e677627cf7bac13485b59b03
diff --git a/net-misc/r8168/r8168-8.047.01.ebuild b/net-misc/r8168/r8168-8.047.01.ebuild
new file mode 100644
index 000000000000..5d05429e616c
--- /dev/null
+++ b/net-misc/r8168/r8168-8.047.01.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info linux-mod eutils
+
+DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
+SRC_URI="${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="fetch"
+
+MODULE_NAMES="r8168(net:${S}/src)"
+BUILD_TARGETS="modules"
+
+CONFIG_CHECK="!R8169"
+ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "using the \"GBE Ethernet LINUX driver r8168 for kernel up to 4.15\" link."
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README
+}