summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/r8168')
-rw-r--r--net-misc/r8168/Manifest1
-rw-r--r--net-misc/r8168/files/r8168-8.044.02-linux-4.11.patch27
-rw-r--r--net-misc/r8168/r8168-8.044.02.ebuild33
3 files changed, 0 insertions, 61 deletions
diff --git a/net-misc/r8168/Manifest b/net-misc/r8168/Manifest
index 3455812608fa..eae877f341af 100644
--- a/net-misc/r8168/Manifest
+++ b/net-misc/r8168/Manifest
@@ -1,2 +1 @@
-DIST r8168-8.044.02.tar.bz2 95880 BLAKE2B f153b077f8112c2b3c81a923a9a9c7d5096d141adb1cc8dd220f9fdf5df32af90c30f19512dc95bb2761febcfe3a59b6634e9fdec8fbb08b6b493a15aad99d0f SHA512 d7e4fd73ee4f17440613b78163777fc0b9e472490a900fdf8e66c4e16f413cc01f49991a68c7bfb19ddf9577e706d0410ff7c8e85ced53e9740e69efda729512
DIST r8168-8.045.08.tar.bz2 104427 BLAKE2B 56e332b518aa3c244750310a77d53ca2fc9a365f4a043e452c5593bcfcd5679c882d35b9977438ddb6a42ba40bb7c9b45e73926fda37c372314d57290ea3ffab SHA512 9037527f193d59da8bcf69396582e13acb58880ce52328e596ffb469352d38649d43f3c31b01ed607773bba1624561f299b3909dd6124448ed75e8f548d80563
diff --git a/net-misc/r8168/files/r8168-8.044.02-linux-4.11.patch b/net-misc/r8168/files/r8168-8.044.02-linux-4.11.patch
deleted file mode 100644
index ba1dd372dfab..000000000000
--- a/net-misc/r8168/files/r8168-8.044.02-linux-4.11.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff a/src/r8168.h b/src/r8168.h
---- a/src/r8168.h 2017-01-11 14:19:18.000000000 +0800
-+++ b/src/r8168.h 2017-05-02 21:18:54.541652414 +0800
-@@ -36,6 +36,10 @@
- #include "r8168_realwow.h"
- #include "r8168_fiber.h"
-
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0))
-+#include <linux/sched/signal.h>
-+#endif
-+
- #if LINUX_VERSION_CODE < KERNEL_VERSION(4,0,0)
- #if defined(skb_vlan_tag_present) && !defined(vlan_tx_tag_present)
- #define vlan_tx_tag_present skb_vlan_tag_present
-diff a/src/r8168_n.c b/src/r8168_n.c
---- a/src/r8168_n.c 2017-01-11 14:18:43.000000000 +0800
-+++ b/src/r8168_n.c 2017-05-02 21:20:57.488644205 +0800
-@@ -25732,7 +25732,9 @@
- if (rtl8168_rx_vlan_skb(tp, desc, skb) < 0)
- rtl8168_rx_skb(tp, skb);
-
-+#if (LINUX_VERSION_CODE <= KERNEL_VERSION(4, 10, 0))
- dev->last_rx = jiffies;
-+#endif
- RTLDEV->stats.rx_bytes += pkt_size;
- RTLDEV->stats.rx_packets++;
- }
diff --git a/net-misc/r8168/r8168-8.044.02.ebuild b/net-misc/r8168/r8168-8.044.02.ebuild
deleted file mode 100644
index 4822eb150790..000000000000
--- a/net-misc/r8168/r8168-8.044.02.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit linux-info linux-mod eutils
-
-DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
-HOMEPAGE="http://www.realtek.com.tw"
-SRC_URI="http://12244.wpc.azureedge.net/8012244/drivers/rtdrivers/cn/nic/0009-${P}.tar.bz2 -> ${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-MODULE_NAMES="r8168(net:${S}/src)"
-BUILD_TARGETS="modules"
-
-CONFIG_CHECK="!R8169"
-ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
-
-PATCHES=(
- "${FILESDIR}"/${P}-linux-4.11.patch
-)
-
-pkg_setup() {
- linux-mod_pkg_setup
- BUILD_PARAMS="KERNELDIR=${KV_DIR}"
-}
-
-src_install() {
- linux-mod_src_install
- dodoc README
-}