summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sshrc')
-rw-r--r--net-misc/sshrc/Manifest1
-rw-r--r--net-misc/sshrc/metadata.xml18
-rw-r--r--net-misc/sshrc/sshrc-0.6.1.ebuild25
3 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/sshrc/Manifest b/net-misc/sshrc/Manifest
new file mode 100644
index 000000000000..23a118178bcb
--- /dev/null
+++ b/net-misc/sshrc/Manifest
@@ -0,0 +1 @@
+DIST sshrc-0.6.1.tar.gz 3701 SHA256 e849ff19319381548011a9bdf1e33abc6eba3dc6a910c4226e6981d75d5564dd SHA512 69e0919bdef0ec6fb187814f1a0dd360b331dc4c0fc047f7767399944eccb949c172682331e6ebe940c275f0a2b6293a66a6018e12351f566638eed1ac362d64 WHIRLPOOL 590e0bad2239466f1f37dd44f04ff9c3dec39d654fe48dbfbb40a607eb82700a50cc01877e231c086ee1895c9c072a8caae7b7f42c5b7184855615abb4bee5ed
diff --git a/net-misc/sshrc/metadata.xml b/net-misc/sshrc/metadata.xml
new file mode 100644
index 000000000000..f0ef82c36f33
--- /dev/null
+++ b/net-misc/sshrc/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>otakuto.gentoo@gmail.com</email>
+ <name>Tact Yoshida</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="mosh">Install Support for mosh</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Russell91/sshrc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/sshrc/sshrc-0.6.1.ebuild b/net-misc/sshrc/sshrc-0.6.1.ebuild
new file mode 100644
index 000000000000..c72989251fc3
--- /dev/null
+++ b/net-misc/sshrc/sshrc-0.6.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Bring your .bashrc, .vimrc, etc. from your local machine when you ssh"
+HOMEPAGE="https://github.com/Russell91/sshrc"
+SRC_URI="https://github.com/Russell91/sshrc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mosh"
+
+RDEPEND="
+ virtual/ssh:0=
+ mosh? ( net-misc/mosh:0[client] )
+"
+
+src_install()
+{
+ dobin sshrc
+ use mosh && dobin moshrc
+}