summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/taptap')
-rw-r--r--net-misc/taptap/taptap-1.0.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/net-misc/taptap/taptap-1.0.ebuild b/net-misc/taptap/taptap-1.0.ebuild
index 414b9b373c9f..f95f52794ab5 100644
--- a/net-misc/taptap/taptap-1.0.ebuild
+++ b/net-misc/taptap/taptap-1.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
+EAPI=6
inherit toolchain-funcs
DESCRIPTION="A program to link two /dev/net/tun to form virtual ethernet"
@@ -16,6 +16,7 @@ IUSE=""
S=${WORKDIR}/${PN}
src_prepare() {
+ default
sed -i \
-e 's:= -Wall -s:+= -Wall:' \
-e 's:$(CFLAGS):$(LDFLAGS) &:' \
@@ -23,9 +24,5 @@ src_prepare() {
}
src_compile() {
- emake CC="$(tc-getCC)" || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
+ emake CC="$(tc-getCC)"
}