summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/udpcast/udpcast-20200328.ebuild')
-rw-r--r--net-misc/udpcast/udpcast-20200328.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/udpcast/udpcast-20200328.ebuild b/net-misc/udpcast/udpcast-20200328.ebuild
new file mode 100644
index 000000000000..ecb6e1be2332
--- /dev/null
+++ b/net-misc/udpcast/udpcast-20200328.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="Multicast file transfer tool"
+HOMEPAGE="https://www.udpcast.linux.lu/"
+SRC_URI="https://www.udpcast.linux.lu/download/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hardened"
+
+BDEPEND="
+ dev-lang/perl
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-20200328-gentoo.patch
+)
+
+src_configure() {
+ use hardened || append-cppflags -DUSE_ASSEMBLER
+
+ default
+}
+
+src_install() {
+ default
+ dodoc *.txt
+}